Weight not syncing from Fitbit [October 2022] [SOLVED]

Same here too. I get one successful sync after reconnecting, but then it stops updating again. I’ve tried revoking access at both ends before reconnecting, but no lasting success. Not sure if it is at Zwift’s end or Fitbit’s. I sync from Renpho scales to Fitbit with no problems, which is then meant to sync to Zwift and MyFitnessPal. Fitbit is syncing fine to MyFitnessPal every day so my feeling is that Zwift is where the problem is.

Same issue. Ticketed it to Zwift. Answer: link to this forum to “help” me… Nice :wink:

It look like it is something that Fitbit has changed. Myfitnesspal is updating but Zwift and Todays Plan is not updating.

I guess it may depend on who runs the API - is Zwift GETting the data from Fitbit, or is Fitbit PUTting the data to Zwift? The API calls may need fixing/updating, but as it works once, is it something to do with the authorisation tokens, and who stores those? There is a recently started thread on the Fitbit community forums.

https://community.fitbit.com/t5/Third-Party-Integrations/Fitbit-to-Zwift-Sync/td-p/5272215/

But it might be worth a few of us sending in support tickets too to get their attention at Fitbit

https://myhelp.fitbit.com/s/support?language=en_US

2 Likes

I’ve had an update from Zwift to confirm the issue is on their radar and they are hoping to resolve it soon. I can’t confirm if the problem lies with Zwift or Fitbit, but at least it’s being looked into.

2 Likes

Cheers Dave, I look forward to this being fixed.

Same issues, following topic.

1 Like

Did you report it to fitbit, see the link above.

Reporting also to fitbit

1 Like

Same issue here - Fibit weight sync not working. Really hope this is looked into and fixed, worked great before.

1 Like

Did you report it to fitbit aswell?

Went to Fitbit today and they pushed this back on Zwift. No help outside of saying if it works in their app, that is all they are responsible for

1 Like

Yes, but seems like this is a Zwift-issue. Hopefully it will get fixed soon.

I have noticed that it is also not syncing with Today’s plan. So it can be that fitbit changed something and Zwift and other apps need to update.

1 Like

Hope they figure this out soon and don’t just give up like they did with Withings. I notice Withings is no longer even an option to connect on Zwift’s Connections pages showing that they threw in the towel there.

@shooj Is this bug in the queue to fix or should we expect this functionality to be gone the way the Withings weight sync is gone. Are there any other connections that submit weight to Zwift that we can try a new workaround, or was this the last one?

2 Likes

@Paul_Himes
We’ve like to bring back this useful feature, but it requires assistance from Withings. They have been unresponsive to our outreach.

@shooj this particular issue isn’t related to Withings integration (although I would like to see that brought back). This issue is with fixing the broken Fitbit integration. Is that being worked on? Cheers.

2 Likes

@Andy_May-Coates

You’re right, my apologies. I was conflating Withings and Fitbit. We’re looking into this.

4 Likes

Hello all,

Fitbit weight should now be syncing properly to Zwift again. Please let us know if you continue to have any issues.

3 Likes