Fitbit Aria 2 weight Scale and Withings scale not syncing

Greetings All, I use a Fitbit Aria 2 scale to weigh myself, and I have setup the Fitbit connection to Zwift so my weight syncs from Fitbit to Zwift. I really need this automation because when it comes to my weight I have a problem with mythomania and cannot be trusted to key in my actual weight to Zwift without proper supervision (slight smile).

The problem is that the sync process is not working. My Fitbit account does sync my weight to both MyfitnessPal and Strava without a hitch. I have searched the Zwift Forums and checked out ZwiftInsider, but found nothing helpful. I also turned off the Fitbit-to-Zwift connection and turned it back on several times. When I do this process, the sync occurs immediately one time, but only one time. After that it does not work anymore.

This problem is not that big a deal, but if anybody has a suggestion how I might get this fitbit-to-zwift sync process working, I say thank you in advance. Cheers, Mike

I’ve noticed this as well. It did seem to work previously.

1 Like

No longer working with the original Fitbit Aria either, though it was working perfectly up to a couple of months ago.

I have since tried disconnecting and r econ W ting my Zwift/Fitbit accounts to no avail.

Fitbit weight sync is broken. I hope the developers take notice.

Has stopped working for me as well.

Same issue here, only bought the fitbit scale to keep Zwift happy by ensuring my weight is accurate so it’s annoying to have to unpair the two every time there’s a change in my weight. Hopefully a fix will follow after the upcoming events as it’s likely development time has been spent on new routes for suggested events.

Same problem here, hopefully this can be fixed quickly!

Did you try to un link and re link the scale?

EDIT:

I noticed the same thing on the Withings smart scale.

Sorry for the belated response. In my original post, I used the less sophisticated phrasing of “turn off” and “turn on” to indicate that I did unlink and relink the zwift-Fitbit connection several times. Each time I do this process, the sync works once right away but then does not work again.

1 Like

My Withings scales also no longer updating to Zwift for about a week while it continues to update other apps such as TrainingPeaks. I’ve logged a ticket.

1 Like

I got the same issue with sync Withings to Zwift and today Zwift support told me to disconnect all other connected apps to Withings. I’ll check that tomorrow and let you know if it works.

@Michael_Witzel did yours work.

No, doesn’t work with just one connection :expressionless:

Thinks.

Mine only update once if I disconnect and reconnect but not the next day.

maybe @shooj has more info.

1 Like

Yes, same here. I have two support tickets open. One at Zwift the other at Withings and it’s the usual ping pong game.

Mr. Delport - I find it interesting that both Withings and Aria work only once after a disconnect and reconnect (previously known as unlink and relink). This leads one to hypothesize it’s a software issue on the Zwift side.

That is my thinking as well. It is probably something that changed in the recent update.

All - we’re looking into it. Thanks for continuing to raise the flag on this one.

3 Likes

Shuji! Thanks much for the response. We all hope it’s an easy one to fix. Cheers.

Thanks for the update and looking forward to the fix when you have it.

+1 on this problem also. My weight is not getting sent via the Withings connection in the zwift companion app. Have tried to remove and then reconnect but it doesn’t seem to have made any difference