Wahoo Kickr not controlling resistance

Ok thanks rob your is the only garmin case the rest suunto. Be interesting if others could contribute with a kickr and ant stick brand 

Resetting and recalibrating my Kickr did nothing. I don’t have another ant+ dongle to try

Same problem here and I have a Garmin dongle

Are zwift able to acknowledge there is an issue since the last update?

I hope so. Now they are open beta it must be effecting a lot of people

I just tried using a laptop that cant actually run the game… but it does detect everything, the difference between the 2 machines is the one that works is using Win 7 and the other which wont pickup anything is running Win 8.1 Not sure what OS others are using. Cant detect if the Win 7 is controlling resistance though as that machine crashes when you launch into watopia lol…

Win 8.1, Suunto ANT+ USB, Kickr, Wahoo HR and cadence

No variable resistance and cadence not found.  :frowning:

Shattered after 1 lap :slight_smile:

I’m running windows 7 never had issues before the last update 

i’m running windows 8.1

i count 7 people on this thread alone having problems.  it’s unlikely to be down to user error or interference.  in my opinion it’s either a windows update and/or the zwift update to blame.  

lets hope it gets sorted soon as i reckon this 7 is the tip of the ice-berg…

I’ve been a long time  user of Zwift and this is the second update that they have done that has had issues with the Kickr, but the first time that my Garmin devices have not paired. Everything was working fine before the latest update. I’m sure they will work it out. Not sure why they struggle the way they do with the Kickr.  

Ah not just me then! I should have checked here first, as I’ve spent quite a while with various Wahoo and TrainerRoad apps trying to figure out if the KICKR was still working properly. Zwift also had problems picking up my Garmin speed/cadence sensors too. Never had any problems before. :frowning:

Zwift, MacOS 10.10.3, Suunto ANT+ dongle USB, Wahoo KICKR

Same problem here after update…


Same problem as all who have commented. Started right after the last update. 

First time I have ever had a problem using Zwift with Kickr.

Same problem here after latest update on CycleOps powerbeam and suunto ant+ stick. Tried everything. Cycleops virtual training connects so it is not hardware. 

Same problem here.  First time user :(.  Suunto mini ant+, Wahoo Kickr, Wahoo cadence sensor, running on Mac OSX (Yosemite).  Everything works fine on Trainer Road.

Same here: Kickr, Suunto mini ANT+, latest update. I also have a Quarq powermeter that I use for cadence, and Zwift was having a hard time picking that up as well.

I’m in the same boat now…using Windows 8.1, suunto movestick mini (on an extension cable so it sits directly under the BB), and a Quarq controlling the kickr.  Tried using the Wahoo app to force it into sim mode, nothing.  I’ve never had this issue prior to the latest update.

Same problem here.  I was in the beta test and never had this problem except for one time and I restarted the app and it corrected it.  I have tried that at least 5 times with no success.  I am also having issues with HR/cadence ANT sensors connecting consistently.  Today, I tried my Trainer Road software and everything worked perfectly.  Something went wrong with the change to open platform.  It is not my ant stick or the trainer  Please help.

Just an update - on my setup - Quarq & 2x Suunto Ant+ dongles.


I found that if I remove all dongles, and close all ant+ apps on the PC, then pulg one dongle in, then start Zwift and let it pair, it works.  Then after that I plug in second dongle, and then run TR, it all works together again.  But before this update, the order of pairing didn’t matter at all.

Just figured I’d mention this in case it helps.