Kickr Resistance Issue

I’ve been having issues with the resistance of my '17 Kickr fading during efforts, sprints in particular. I’ll be in the 52/12 gearing and hop out of the saddle, I’ll get a nice peak power, but after about five seconds the resistance eases off and I’m at 100+ rpm and barely getting 600w of power, about a 300w power drop. And I’m getting killed in the races because of it.

Wahoo has reviewed my .fit files using the Wahoo Fitness App and tells me the trainer is performing as it should. I have no idea what’s going on. I’ve played around with the “Trainer Difficult” setting, moving it from 60% all the way down to 0%/ OFF and the results are the same.

Anyone have a clue what’s happening?

If anything you’d want to move the “Trainer Difficult” setting towards 100%. The default 50% should be fine for most people.

I would double check your device pairing in Zwift, specifically power and controllable trainer. Assuming you have no other power meter, since you didn’t mention one, make sure both the power and controllable trainer are paired to the Kickr.

If you’re using ANT+, select the FE-C option for both power and controllable trainer. For example, you do not want to select “kickr” for one and “kickr FE-C” for the other.

I used to have it up around 60% and was experiencing the same resistance drop off.

I am using ANT+ and pair with the FE-C option. Not even sure why Zwift even has the other on the list to begin with. Today, I tried using Bluetooth, pairing the Kickr, the Tickr HRM, and even threw on the Wahoo cadence pod, and found the power numbers jumping too wildly for my liking, going from 180 to 150 to 220 and everywhere in between with a steady cadence on a flat road. Then when I got up to sprint, I lost all power – watts and cadence dropped to 0. So I went back with ANT+.

I just don’t understand what’s happening. Others I know are using the same gearing and turning out the same rpm (or even lower in some cases) and are putting out 200w more than I am. Their power curve is nice and smooth for the duration of their sprint, while mine nose dives after five seconds. I should not be in 52/12 and turning 100+ rpm and not getting much more than 550w after the initial spike of peak power I get when I hop up.

1 Like

Try it again w/out the Tickr HRM and w/out the cadence sensor. Select the Kickr FE-C option for both power and controllable trainer. Give it a spin and see if that changes anything. I assume your Kickr firmware as well as Zwift are both updated?

I have had a Kickr Gen1 which worked w/out issue. However, I have never used had a Tickr HRM (Garmin and Viiiva here) but I swear that I see a lot of problems w/people who have the Tickr :man_shrugging:

So the Tickr HRM could be a cause of this? I’ll go back with my Garmin strap then and see if that helps.

What’s the cadence sensor have to do with it thing, though? How would I get rpm readings if I remove it? (It’s a Garmin one, btw, not the Wahoo one).

I’ll give it a go this morning and see if it has any effect.

Nope … that didn’t help at all. 850w peak down to 550w all while turning 105 rpm.

I had this issue on Ant+ with interference from my Garmin edge and/or watch. Turned these off and it was fine. Have since switched ant+ laptop to Bluetooth iPad and no issues

Well at least you know it’s not caused by the Tickr or cadence sensor. Zwift will estimate cadence if you don’t have cadence paired. In my experience, it is sometimes spot on and at other times completely unusable.

What kind of ANT+ dongle are you using? How far away is it from your trainer? Moving it closer via a USB extension cable if you haven’t already done so would be my next recommendation.

As for Bluetooth vs ANT+, one could work better than the other, they could both suck, or both be great. It depends on your environment. Bluetooth and ANT+ are using the same 2.4GHz frequency spectrum which is also used by WiFi. It might help you to move your WiFi to 5GHz if you can to eliminate some interference.

I’ve got a Garmin ANT+ dongle attached to an extension cable and placed beside the leg of the Kickr.

Perhaps I could look into somehow switching the ANT+ frequency to 5GHz, but I’m not sure how to go about that. My laptop is connected via Ethernet, and my internet is 1gb, so I know the connection is about as good as it can get. But something is definitely messed up somewhere, and I really need to figure it out.

Any reason you’re using ant connection instead of Bluetooth from your laptop (for the trainer?)

Maybe it’s not the connection or the electronics in the unit. Ant+ that close with a wired 'net connection should be 99.9999% uptime.

What about the hub/freewheel?

Might be worth the time to take it off and inspect it all to make sure everything looks good and is engaging correctly.

Maybe the answer is mechanical in nature. (Don’t know - can’t see or hear it.)

You can’t switch the ANT+ frequency. I was referring to your WiFi which is either 2.4GHz and/or 5GHz depending on your WiFi router. If you can move your house WiFi to 5GHz, even if it doesn’t solve this problem, it would still be a good thing.

Another suggestion is that you grab a log file and feed it to Zwiftalizer Then you can see if you’re having any ANT+ signal quality issues, network issues, etc…

1 Like

Get rid of the ANT+ dongle. They can be flaky in my experience.

Try going exclusively Bluetooth for all you connections. Beware though BT is not without its issues. The device can only pair with one other thing at a time (unlike ANT+) This means of you can’t pair the kickr, then make sure its not paired and connected with something else.

Marco, I found the Bluetooth very buggy. I tested it yesterday and found the power numbers jumping around way too much for the steady cadence I was holding. Once when I got up to sprint, the power numbers dropped off to zero, so at that point I switched back to ANT+.

Lin, my new Comcast WiFi modem transmits at both 2.4 and 5GHz. One thing I did do last night (though haven’t logged in to Zwift to test) was change my laptop’s WiFi network, switching from the cable modem to the Ethernet connected Netgear router I have downstairs (which I recently set up to boost the signal for my TV). Because the laptop I’m running Zwift on is also Ethernet connecte, I never put much thought before into how the ANT+ of the Kickr, my HRM, and cadence sensor would be transmitting data to the laptop. Would it be safe to assume that although my laptop is hardwired directly to the cable modem that it is also utilizing the WiFi for the ANT+ devices?

Christopher, over the past year I’ve pretty much rebuilt the Kickr with parts Wahoo sent me in an attempt to solve the issue. I actually sent it back in to them and they changed my power control board. Wahoo suggested I do another test using their fitness app with the level set to 3 or 4. Here is their reply:

Everything I can see on the backend points to the unit preforming a designed. If you continue to experience problems with holding a high power please set the unit to a trainer difficulty or level that is not 0 and send over a fit file. Having no actual brake resistance will produce a high power number when the flywheel is spun up and it will drop off as the flywheel “outspins” the input.

Not sure how that translate to Zwift, as there is no way to adjust the “level” in game.

Are you able to disable the 2.4GHz? But before you do so, does your laptop and other devices such as your phone all support 5GHz?

ANT+ will not use your WiFi. The ANT+ transmissions are all via the Garmin USB ANT+ dongle to/from your devices (e.g., Kickr, HRM). If you plug the laptop into the ethernet (hardwire), I suggest you disable the laptop WiFi and test the trainer again. If it all works as expected, then you can unplug the ethernet, turn on the WiFi again and test w/the WiFi. This way you might determine if it’s the WiFi.

Again, I suggest dropping a Zwift session log file into Zwiftalizer which might help you figure this out:

I just uploaded Saturday’s log file to Zwiftalizer, but from what I can tell all looks good …

2 Likes

That ANT+ look solid. No problems there.

1 Like

@Derek_Rush

As @Gerrie_Delport already stated, that ANT+ looks pretty solid. If you zoom into the timeframe when you go for a sprint and it drops resistance and/or power, what does it look like? Anything stand out?

Since you have ruled out other things, is it possible that your resistance unit is overheating and the magnets lose strength? Quickly stop and touch the unit when it fades to see if it is very hot. You may have to add a fan directed at the unit.

R Law, no, while in the summer months it can get really hot, this time of year the flywheel is only warm to the touch. I do actually have a small turbo fan always aimed at the trainer to keep it cool; it’s just something that I’ve always done. The problem, in my opinion, has something to do with the break easing off after I get past that initial torque of a sprint. It doesn’t maintain resistance, and for the life of me I just can’t get the power to stay above 600w, regardless of the cadence. It’s almost like the Kickr keeps adjusting to keep the maximum power governed or something if that makes any sense.