Vector 3s not connected to Zwift (not even recognized)

pairing-error

(Sam Bruyninckx) #1

Hello,

I try to pair my Vector 3s to Zwift but Zwift doesn’t even recognize the sensor. Speed sensor is recognized so i don’t think there is a problem with the ANT+ dongle. Pedals are doing great on the road - they get recognized by Garmin Edge 820. Why can’t Zwift pair with the Vectors. I already tried to reinstal Zwift, but it didn’t work out.

Any suggestions?

Thanks!


(Paul Allen (Watopia Wayfinder)) #2

What device are you running Zwift on?


(Sam Bruyninckx) #3

Tacx Booster.


(Sam Bruyninckx) #4

Windows computer.


(Paul Allen (Watopia Wayfinder)) #5

And you are using an ANT+ dongle?


(Sam Bruyninckx) #6

Yes. With a cable extention. Signal is good, but when i ask Zwift to search Powermeter, it doesn’t find anything.


(Paul Allen (Watopia Wayfinder)) #7

Do they still pair with your 820? Might be worth checking since it could be a battery issue.


(Sam Bruyninckx) #8

When trying to pair with Zwift i don’t activate my 820…


(Paul Allen (Watopia Wayfinder)) #9

Just try and test to see if they will still pair with the 820, ANT+ will allow you to connect to multiple devices at the same time.


(Sam Bruyninckx) #10

Still not working… Edge 820 works perfectly.


(Vincent) #11

Hey Sam, is the battery fresh in your Vector 3s? You may need to send in a support conversation if you haven’t already.


(Ales Susnik [VISION] (B)) #12

Can you upload your log file somewhere so I can see it?


(Bruno Pelletier) #13

Hi there, have exact same problem with Vector 3 (dual side). Using Windows10 PC. Zwift detect and connet to HR sensor and Tacx Neo through my Ant+ dongle, but not the Vector 3 pedals. Did not have the problem back in march-april 2018 with 1st pair of Vector3, but started heving the problem with replacement pair of Vector3 in October .


(Sam Bruyninckx) #14

Indeed. That’s exactly how it went. Got me a replacement pair of Vectors in octobre and since then i can’t pair anymore. Prvious pair didn’t have this problem. Seems like it’s a Vector3-specific problem.


(Andrew Hartzell) #15

I am having the same problem. I just created a Zwift account today. Other sensors are pairing just fine, but I cannot pair my vector 3 peddles. I want to use Zwift on my rollers so the power meter is key.


(Andrew Hartzell) #16

I reached out to Zwift Support, but they didn’t have any suggestions. Does anyone have a support phone number? The Vector 3s are working perfectly, but Zwift isn’t picking them up.


(Bill Noorlander) #17

Has anyone found a solution to this? My Vector 3’s were working perfectly until two days ago and now they don’t even show up in Zwift.


(Andrew Hartzell) #18

Reach out to Zwift Support. The more of us that contact Zwift the better.


(Michael Van Arsdale) #19

Same issue here. U have a new set that work fine with my Fenix, but Zwift cannot find them. I replaced the batteries and moved dongle within a foot and still nothing. I reached out to customer service but I have not heard anything yet. Hopefully they figure this out soon, it’s very disappointing.


(Ales Susnik [VISION] (B)) #20

Has anyone uploaded their log files anywhere so we can have a look in there for errors? :slight_smile: