Using Zwift on laptop and Companion on phone without WiFi

I have my bike set up in the barn on a Wahoo Kickr with no WiFi out there. I connect my laptop with Zwift app to a wall mount flat screen TV, and have Connect on my phone. Running app on laptop via hotspot on my phone. Zwift properly connects to my trainer’s power and cadence, and my chest strap heart rate monitor.

Few problems:

  1. Zwift on laptop does not engage erg-mode. I can only workout with manual shifting.
  2. I cannot sync Connect on my phone with the workout on my Zwift app on the laptop.

I am able to run Zwift on my phone, workout in erg-mode, and connect to flat screen TV. But would like to use my phone instead for tunes etc. and run Zwift on my laptop.

HELP PLEASE!

How does your laptop connect to the internet? Fixed cable or through your shared (hotspot / tethering) mobile phone connection?

Laptop connects through mobile hotspot.

Bill Meerman
614.330.7812

Hello Bill, just tested it out. Laptop on WiFi, Bluetooth enabled on laptop and on cellphone. Cellphone mobile hotspot on. Shares connection with laptop. Training started and ERG operation via companion on mobile phone. Works fine. My phone is on developer mode and Android. So I can activate and share mobile connection and WiFi at the same time. WiFi sharing is blocked on some devices, but can still be set if you activate developer mode. Is your Bluetooth on your laptop turned on?

Whenever I’ve used my mobile hotspot to run Zwift on my laptop or AppleTV the in-game functions of Companion app on my mobile phone have never worked. I think it’s one of the limitations of the way they’re set up and needing to be on the same network.

1 Like

Thank you Francis. Bluetooth is activated on both devices. Difference between my set up and yours is that I do not have WiFi out in the barn. All running on my cell phone hotspot.

James, thanks much. Frankly not necessary that I use Companion on my phone. Was simply doing so if necessary to control erg mode on my laptop. What if I simply use my phone for hotspot, which allows Zwift app to run on my laptop. My experience is that erg mode on the laptop does not work. Again it does if I use Zwift app on my phone and ditch the laptop.

It works for me without an external WiFi signal. Just the Android hotspot? The laptop runs Zwift via the mobile phone internet connection? And I can (erg) arrange the workout using the companion. But beware, my phone can activate mobile hotspot and WiFi at the same time! You can try sharing the internet connection via Bluetooth and activating your mobile hotspot at the same time. Never tried this myself. What we used to do during holidays where we took the smart trainer with us: my mobile phone as a hotspot, my wife’s phone (or tablet) running companion and Zwift running on the laptop. This does require a third device.

I cannot get into developer mode on my Apple 13 Pro with IOS 17.2.1

I’m not really into IOS. Born Droid user. Hopefully the apple :apple: guys can help you out.

1 Like

Cellular brand aside, I’m astonished that I’m unable to operate at least Zwift in ERG mode on my laptop with a signal from my cellular hotspot. There’s got to be a solution here. Is ERG mode a given in normal operation with my Wahoo Kickr and Zwift or is that something I have to enable in Zwift settings? If the latter, I cannot locate an ERG mode toggle.

You can try to switch Bluetooth on your phone off before you run Zwift on the laptop.

This sounds odd, as far as your laptop is concerned it is connected to wifi, it doesn’t necessarily know it’s a phone or not.

To try and isolate it I would turn off Bluetooth on the phone (do this from settings, not the shortcut pull down from top right since this doesn’t fully turn it off). Make sure the Zwift and Zwift companion app are not running on the phone (kill them, swipe up from bottom and if they are there then swipe them up). Then start Zwift on the laptop and connect everything, the kicker should be connected as power source and controllable.

Then try a workout and see if erg mode works. If it doesn’t, if you do a free ride does the resistance change to simulate hills?

ERG mode should work regardless of how you connect to the internet, the two aren’t dependent on each other as far as I know. This could be a settings issue?

Do you feel resistance changes when doing a free ride with this setup? Do you feel the hills when not doing a workout in other words.

Hi Mike. I definitely don’t feel any resistance. No ERG mode. Instead I have to manually shift. Don’t know why that is. I see no settings to allow me to utilize ERG.

I’ll try this today.

David, will try this today. Thank you.

sounds like you aren’t paired correctly to Zwift, David’s tip should help.

Phone Doesn’t allow me to turn on hotspot without Furst enabling Bluetooth on the phone?? Grrrr

it appears to be optional to have bluetooth on, according to your screenshot… I am not convinced that the bluetooth on your phone is causing the issue anyway. I think you aren’t paired to the trainer correctly and need to have both power and controllable (or is it called resistance now?) connected at the pairing screen.