Uploading to Strava not working (March 27 2020)

So I completed my first century ride on Zwift this morning/afternoon. Once finished, I pushed save and exit, assuming it would be posted on my Strava profile. It was saved on my Zwift companion app but has not appear on Strava.

I have gone in, and disconnected my Zwift account from Strava and then reestablished the connection. I also checked the fit file, so if I had to, I could just manually upload the ride. But when I look at it, it says it is an “inProgressActivity”.

Any help would be greatly appreciated.

1 Like

2 rides I’ve just done have not sync’d to Strava - this possibly is related to the last update? - it was fine yesterday…

I manually put up the .fit file for the first. the 2nd later after some recovery :slight_smile:

How were you able to recover it?

I noticed there was an update, but now my computer isn’t letting me update it for some odd reason.

Give it a bit of time, I have noticed that there is no new activities form my friends in Strava for the last 4 hours.

EDIT:
Although it looks fine on this site.
https://status.strava.com/

1 Like

Ya, a little patience probably wouldn’t hurt. Thanks for all the responses!

Be safe. Be healthy.

Gang - we are aware of this glitch and are working with Strava to sort it out.

4 Likes

Thanks for the update. @shooj.

That you @shooj!

Zwift has the best customer support out there.

1 Like

Broken for me too. Even tried uploading it from Garmin Connect. Totally broken.
Normally takes 5 sec now it isn’t showing after 3 hours.

Hi guys, it look like things is going to strava now.

1 Like

@Gerrie_Delport it has, thanks!!

1 Like

Thanks and good job

Are people still experiencing this issue?

For me, the problem still persists. 2 of my last 3 rides havent uploaded to Strava.

All my issues (Zwift wise) have been resolved.

Yes, my first ride today has not synched with Garmin or Strava, have tried connecting and disconnecting still no joy !!

Same here. Ever since upgrading to MacOS Catalina 10.15.3 my connections to Strava and Garmin seem to have broken… I’ve upgraded Zwift to 1.0.48307 and companion used is 3.12.0… I get the .fit files that i can upload to strava but events are listed as dates in companion and not the name of the ride i did… Tried disconnecting snd connecting a few times. no success.

Same here since yesterday dont uploading my workouts on zwift from Apple TV and Android Device too.
My Provider is Unity Media(Vodafon)

Same issue here on April 2 - Zwift sync to Strava and Garmin no longer working. Both were fine yesterday. Tried disconnecting and reconnecting but still same issue.

Since 2 days no sync with Zwift (MacBook (Catalina)/IPad) and no sync with Strava. My rides just disapear. Not popping up in Companion either… Whats wrong?!

Same issues with uploading either to strava or garmin connect. Seemed to be working well the last days for me and now not. I’ve tried disconnecting and reconnecting through zwift and both apps without success. My ride shows in my events in zwift. Thanks!