Unpredictable resistance while climbing

Evening hive mind!

Has anyone experienced and or solved very unpredictable resistance changes whilst climbing?

On thé alpe my resistance is changing indépendant of displayed gradient, I’ll be grinding on 7% then spinning happily on 14% ramps four gears down!

Really spoils the climbing experience as the low resistance parts are definitely not there in reality!

I also felt a lot of resistance was still there on the decent, wasn’t able to ‘soft pedal’ to recover, felt like flat/ false flat, certainly not like -10%

I’m on macOS Catalina on a MacBook Pro, fresh installs of latest zwift and companion app, Kickr Core with Bluetooth connection, no apps other than zwift/companion open anywhere.

Tried spin down/ factory spin down / delete and reset and re pair - same issue.

No problems in erg mode that I’ve noticed

Anyone else seen similar?


Some thoughts:

  • The gradient on the Alpe is constantly changing. I am not sure the display on the screen is always keeping up. Also there is lag depending on your trainer. My Saris H3 lags by 2-3 seconds. This is what makes the Alpe great/difficult…or a PITA … depending on your view.
  • Where do you have your trainer set for gradient resistance? Once in Zwift go to Settings…where is the slider? Default is 50%. So if the gradient says 10%, your pedaling resistance will feel like 5% gradient.
  • Downhills are half…so if it is 10% downhill and the slider is in the middle (50%), the actual “feel” will be 10% x 50% x 50%…so 2.5%. Zwift’s philosophy is to work uphill and downhill.

I’m on default 50% trainer difficulty, and yup I know Zwift halves the downhills, but to be pushing 170w in 30/28 just to keep a Cadence above 80rpm seems very odd - there were sections on the climb that felt like less resistance! But to be honest I wouldn’t care about this if the climbing side was working as it should.

I guess the constant variation and trainer reaction time could be be part of it, but I can’t see how rolling from 8% onto 14% would result in a reduction in resistance? I’ve ridden it on a different trainer and those ramps are not so short that a trainer couldn’t react, I’m not riding that fast!

I’ve seen a few similar’ish issues popping up mentioning the Core. Just did a quick search and found these below. Might be some useful feedback in these threads for you.

Thanks @Dean, I guess I’m not alone, but seems like no solutions exist as yet beyond keep deleting and uninstalling the app with fingers crossed!

1 Like

Did yet another full delete/reinstall, deleted all Wahoo, Garmin apps and left phone on flight mode. Trainer had been unplugged overnight and then re-paired to fresh install of Zwift (macOS via Bluetooth) Nothing else bike related on / open / installed anywhere.

Same issue, rolling in on 0% feels ok, ride onto 10% and trainer resistance drops (slightly, but noticeable, needed a shift down to hold same cadence) ride up 10-11% for a few minutes - resistance stays steady, U turn and ride down same 10% grade - resistance stays the same, with eyes closed and someone else controlling you would not feel any change from +10% to -10%

So frustrating

If it hasn’t been said already. Make sure when you sync your trainer before the ride it’s on “ANT+ FE-C Controllable Trainer”. Use a dongle and place it closer to your trainer to allow faster communication between the system and your trainer.

Without this my trainer lags 3-5 seconds and on punchy courses like Crit City the climbs are over before the resistance even kicks in!

I’ve made some progress on this, after managing to grab some other devices to test on… posting in case it helps anyone else trying to find the source of similar issues.

Same trainer, same setup but running Zwift on both an Apple TV (gen4) and iOS is a totally different experience, smooth predictable changes in resistance that actually match the grade!

Seems to be an issue around how the laptop handles BLE connections with the trainer. Not sure if it’s the OS, Zwift build or laptop hardware that is causing it (yet)

By using the companion app to ‘bridge’ the connection and connecting the Zwifting laptop to the trainer via the companion app, I’m able to get most of the feel of the iOS experience (it’s still a little slower, and feels somehow less smooth in adding / subtracting resistance)

Interesting these seems to be a noticeable difference in ride feel between iOS (great) / AppleTV (ok) / MacOS (almost unridable) when you ride them back to back on the same course.

I’ve ordered and ANT+ dongle to see if that lets me take the companion app out of the loop whilst still avoiding the laptop/BLE weirdness, but the bridge seems to be working as a ‘work around’ for now, may well work for others!



I’m having similar issues to you with the weird resistance while climbing/ descending that is ruining the whole experience. I’m running Kickr Core and Windows 10 laptop with latest Zwift and Kickr updates (only bought the Kickr 10days ago so brand new). Impossible to ride with groups when the resistance is totally off - although I did do one ride in Watopia yesterday that seemed ok.

I’m going to try running on my ipad to see if it makes any difference. Also seen several tips on rewinding Kickr firmware to an earlier version but not ideal if it can be avoided.

morning, I didnt have such problems but after the last update I have exactly the same issue.
Resistance changes in a random way and there is no matching between uphill degree and resistance of the kickr.
I am new to zwift and thought that tried also to do different routes / trainings to see if the issue persists.
User experience completely dropped, while trying to do trainings is practically impossible
I have a brand new Kickr and using win 10 on my laptop. I now tried to delete and re-install the app and hope it gets better.
thank you all

Hey Francesco, If it helps - after much back and forth I ended up with a USB ANT+ dongle, extended out behind the kickR, and have had no issues since. I have swapped back to BT just out of curiosity (as I know the newer Zwift and Kickr firmware versions added better Bluetooth functinoality) but the issue remained. Not sure if it’s my device, environment or software, but for me it just does not work reliably and neither Wahoo or Zwift could figure out why. A 15 euro dongle completely changed the experience. Good luck!

You just saved me an immense amount of frustration. Can verify, after updating everything, deleting and reinstalling everything, double-checking settings, I also saw that the iOS route is the only thing my Kickr, climb and screen are in sync with. I alternate between iOS, and macOS