Kickr Bike resistance issues at high gradient

My Kickr Bike doesn’t like gradients of around 10% or more. Everything is fine on the flat but as soon as the road turns up I get totally random resistance changes. One second resistance is as it should be, next I’m in the spiral of death. Radio Tower climb and AdZ are main culprits. I’m running Zwift on PC (Windows 10) with power, cadence and controllable connected via Bluetooth. No other apps running. I can see there are other threads dealing with similar issues, but none relating to higher gradients. Hoping someone has some words of wisdom.

For the issue to only exist at certain gradients sounds a bit peculiar as Zwift doesn’t handle higher gradients any different than lower gradients. Can you check if you’re on the latest firmware for your trainer and then do some tests with your Trainer Difficulty slider. I’d like to see if the same issue pops up at different gradients depending on where your slider is set. For example do the issues pop up at 10% on 50% difficulty and 5% on 100% difficulty.

Thanks Lucas. I am on the latest Firmware. I’ve just run a few tests as you suggested. The random resistance changes seem to kick in regardless of trainer difficulty. The only new info I have from the tests is that the resistance changes only seem to occur at higher power outputs. At 100% trainer difficulty I will climb a 10% gradient at around 290w at 95rpm in granny gear and then the problem occurs. At 50% difficulty I will climb the same gradient at around 170w at 95rpm in granny gear but the problem does not occur at this lower power output. However if I shift up a few gears to replicate 100% difficulty (290w at 95rpm) then the problem occurs again. Note the problem does not occur at lower gradients. I tried both 100% and 50% difficulty at 5% gradient without a problem. These resistance changes also occur at totally random times, there is no consistency to them. Sometimes they happen right at the start of the climb, sometimes a couple of minutes in. And sometimes the problem lasts 10 seconds and at other times maybe a couple of minutes. It feels like an interference issue but I just don’t know what could be causing it…

The fact that you don’t encounter the issue on the lower trainer difficulty until after you shift gears and put out more power sounds suspiciously like the issue is coming from the trainer since Zwift just sends gradient targets and the trainer handles the actual resistance.

A couple quick tests that should help rule this out further would be to see if we can reproduce this issue with no gradient at all. Probably start with a ride on Tempus Fugit, or some similarly flat route, and see if you can’t work your gears in a way that gets you in that 290W at 95rpm range and see what happens. You could also create a custom workout with a 290W block in it and let the trainer handle the resistance while you get your cadence up but that won’t quite be a 1 to 1 test since it would use ERG mode. The most definitive test would be to try and reproduce this with a bike computer or other app if you have one handy.

Recommend to try ant+ connection if possible.

Also give it a go with other software if you have them.

Hi Lucas, sorry been off line for a bit. To answer your previous question, yes this does appear to be a problem on the flat also. I did a ramp test yesterday and the photo shows the resistance through the pedals freaks out when I hit 380w. Today I did a hard reset on the trainer, checked the firmware, and re-did the ramp test with my phone turned off (I use Zwift on PC). Exact same result. So in other words the problem is occurring in both ERG and SIM mode and regardless of gradient. It’s got me stumped.

Just an update - yesterday’s ramp test was done with each of power, cadence and controllable being connected via Bluetooth. Today I connected each of power, cadence and controllable via Ant+ and did the ramp test again. Exactly the same thing happened again, the resistance through the pedals freaked out upon reaching 380w. So it doesn’t appear to be a Bluetooth vs Ant+ thing.