Odd resistance changes in ERG mode [September 2021] [1.17.x]

Strangely, we have been having odd erg response and feedback for a good while (delayed or out of sync resistance) using Apple TV - My other half did the Zwift workout yesterday and the erg resistance was fine through the ride.

We are Wattbike Atom connected as controllable, cadence & HR all connected to Apple TV. via Bluetooth. No companion app.

I would need to check if we are 1.17.0 or 1.17.1 if you need additional info.

There is still the issue of the gears failing to work after ending the erg workout and you need to fully shutdown the ATV & reboot the Atom whereas previously you could change gear fine post erg workout and moving to free ride.

I’ve been having this issue using the ATV, Kickr snap, and iPhone companion app. No issue when connecting directly to ATV.

I’ll also note that resistance seems incorrect when in sim mode using the companion app — some days too high, some days too low.


Having issues with resistance using Kickr Snap, Apple TV 4K (1st gen with tvOS 15) and Zwift Companion app in Iphone 7 (iOS 14.8).

Issues have always been sporadic and intermittent since using ZC to bridge all BT connections to ATV. No change in resistance during uphills, downhills or training with ERG mode on, issues are fixed with a combination of closing ZC or turning BT off and on again or restarting app in ATV.

Since sept 20th, issues with ERG are permanently not responding to above fixes. Trainer resistance starts too high once route is started and wattage displayed on screen is higher than normal. No change in resistance during uphills, downhills or ERG training. Cannot complete spindown. Workaround to this issue is not using ZC and connecting directly to ATV. Downsides are not able to connect trainer, HR monitor and cadence sensor all at the same time (usually leave out cadence data or use an app to have it on the phone’s screen)

Bridging BT connections using ZC has always been shaky and outright laggy.

On older versions of ZC, it was much better having the flexibility to choose which BT connection to bridge using ZC, rather than having to bridge all connections using ZC.

Please return to having the ability to choose separately which BT connections to bridge to ATV when using ZC.

Best setup (for me) was having trainer connected directly to ATV BT (upside is instant ERG mode resistance changes and no ERG waffling) and having HR and cadence bridged using ZC on the same BT connection to ATV (these signals and data are not so sensitive to lag).

Hope I’m able to help having the issue fixed

1 Like

Using ATV 4K 21, Kickr, Favero Assioma, ZC as bridge, dual record (usually) with Garmin 1030.

This last update to 1.17 totally jacked my whole system. In normal riding, my resistance is way too high and lags behind the terrain. Erg mode just flat out doesn’t work, even if I turn everything else off. I’ve restarted all systems and deleted apps and updated all software and firmware. I’ve tried doing spin downs, but they almost all fail. This is infuriating.

Experiencing this problem in SIM mode.

Using Kickr Core, Macbook Pro, Bluetooth

I’m brand new to Zwift. Unboxed my Kickr Core and updated to the latest firmware (v1.1.1) Then downloaded a new installation of the Zwift app (9/21/2021).

Resistance on my trainer is working fine. I was able to connect to the Wahoo app, perform a spindown, and manually adjust the resistance settings. So I know my trainer is good.

The problem I’m having is syncing the resistance to my ride in Zwift. Bottom line: the resistance is inaccurate and seems to change on a whim. There’s no correlation between what grade I’m riding in Zwift and the resistance I feel on the bike.

I can be riding up a 20% grade comfortably in my big ring, and then grinding my lightest gear on the way back down. Sometimes I convince myself that the resistance is just lagging, but then other times I just think it has a mind of its own.

Super frustrating because it takes away from the immersive experience I was promised using Zwift.

Been poking around these forums in search of an answer. I’ve tried unpairing and deleting the Wahoo app (so that I’m only paired with Zwift), but that hasn’t worked. I’ve also tried reinstalling Zwift and restarting my trainer…both without luck.

Next step is to try running Zwift on my iPad Pro. And then maybe on my iPhone 12. Not sure if the issue has to do with the Bluetooth connection? Maybe I’ll go pick up an ANT+ dongle for the computer and give that a whirl.

Hope to get some feedback/resolution on this soon. Been excited to ride Zwift for a long time, but this issue is leaving me very disappointed thus far.


Agree – this sucks.

I think I’m having the same issue. Keep us updated if you find a solution.

All - check one thing if your resistance is waffling (either SIM or ERG mode).

  1. If using a laptop/desktop to run the Zwift game app: do you have another program installed that can hijack the trainer’s Bluetooth signal? Garmin Connect / Strava / Wahoo / Saris / etc?
    Some of these programs run in the background any time you fire up the laptop and are interfering without you even realizing it.

  2. Same deal with your smartphone if you have any apps like these installed.

For the sake of troubleshooting - please check for and uninstall any apps like these from both your computer and your smartphone.

Personal anecdote - I had Garmin Connect running on my smartphone and my resistance would drop to zero for no discernible reason. Once I uninstalled it - this problem went away. I do not want to seem like I’m picking on Garmin - this can happen with other third party apps too.

1 Like

I thought this might be the case, so I tried riding with my Garmin 1030 on/off/and with Kickr disabled. Nothing changed. What’s also really strange is that I’ve been riding with the Garmin dual-recording for months with no issues (and so do most of my friends who use Zwift). I don’t have any apps on my AppleTV that would interfere. I was listening to music via Bluetooth (Airpod Pros), but again, I’ve been listening to music/podcasts/Discord calls for months without interfering with Zwift and now suddenly the connection with my Kickr is totally wonky.

Speaking of which, I’ve noticed that when my Kickr is connected to Zwift and my Garmin, it will occasionally change incline levels randomly within workouts or when I’m just riding around in Zwift. This has never happened until this software update. During a recent ride, I was wondering why my resistance was so high while riding on flat ground and I found that my Kickr/Garmin had “automatically” increased its incline to 1%. I’ve tried riding without the Garmin or with the Garmin-Kickr connection turned off and, oddly, it doesn’t seem to solve the problem–it just means that I can’t adjust the incline back to 0%. Somehow, it seems that Zwift is communicating with my Kickr and pushing it into a higher incline at random moments in my ride.

One of the issues is the out of sync change of resistance… I get you’ve put an update in that shows something, but genuinely that is not going to be the cause of resistance being out of sync.

Asking end users to delete multiple apps from their set up to over come a zwift induced issue is just lazy support…

Buts it’s friday, got to make it look like you updated the thread before the weekend.

1 Like

I am have the same issues as those mentioned above. Erg mode lags, resistance adjustment due to terrain changes not in sync. Using Apple TV 4K and Kickr Core. I uninstalled the Zwift app and reinstalled. Worked twice and the issue returned. No other apps are open in the background.

1 Like

Erg mode not functional. Long time user. setup is Wahoo Kickr and iPad with Bluetooth. Firmware UTD on trainer. Trainer not paired with anything else. No functionality with an ANT+ and PC setup either. PC Zwift is updated and I deleted and reinstalled Zwift app on the iPad. Trainer and PowerTap pedals connect to the app. In game, app says that Erg mode is temporarily disabled and then tries to reactivate it with no success. The menu at the bottom says that Erg mode is ON. When I select a workout, Erg mode is selected but all I can do is 20 watts.

Update to my post above…

Had success today using my iPad Pro. I hadn’t used my iPad for any bike-related training before, so there were no other apps or prior history of BLE connections that could have interfered. Resistance on the trainer synced with Zwift perfectly (and my ride was WAY more fun).

For those still experiencing issues – try using a new device if you have one. Worth a shot. Worked for me. Hope to see this bug fixed for good soon tho.

I am having a more normal experience but still having issues. Still experiencing climbing in gears id use for a huge descent like big chainring and 11 cog and descending in my 28 cog because the resistance is randomly oddly reversed. I am no longer running the Swift companion on my phone which some on this forum had suggested as that was giving him issues.

PLEASE get it fixed. The indoor trainer season is fast approaching and winter training is gonna suck if this can’t be ratified.

1 Like

Hi there I have been using Zwift since March 2021 using a Wahoo Kicr Core and an Apple 4KTV. All has been working great since latest update. Since the latest update I have no ERG and in SIM mode resistance changes are delayed by around 15 seconds. At the moment I can only use Zwift for desert runs (ie no hills) and I am unable to complete ZA. When are we going to get a patch to fix this bug? This is basic functionality - it is a pity we cannot revert back to the previous version until this is fixed :disappointed:

Tyler–I also did a ride on iPad this weekend, and it worked better than previous rides on ATV. That said, I didn’t try an ERG workout. Moreover, my 9" iPad is a much less satisfying experience compared to my 106" projector screen. :laughing:

1 Like

Using Kickr V5 with Apple TV 4K 2021. Kickr and HR monitor connected directly to apple TV, not via companion app.

In the last couple of weeks have had issues with ERG mode providing very low resistance, can do 75 W max. It seems to be not providing the required resistance for the ERG power but also not operating in SIM mode and changing resistance with gradient either. Toggling ERG mode off and on does not do anything.

Uninstalling/re-installing zwift seems to mostly fix ERG mode - when starting a ride it seems to be at very high resistance because I’m doing 0 W - I basically have to do a track start and push down a ton of power before ERG mode sorts itself out. Then it’s fine after that for the rest of the ride.

SIM mode seems to be working fine.

Using iOS companion and Zwift on MacBook Pro (M1), Mac OS Big Sur and Elite Arion Smart B+ rollers with latest firmware

Major connectivity issues using companion app and Zwift on Macbook Pro after latest update. Once paired, the resistance is way off - way easier than it was previously. Resistance doesn’t seem to change with grades, though, going downhill - the faster you go, the more resistance there appears to be. Seems backwards.

No other device changes made prior to update and followed all troubleshooting recommendations - uninstalled and reinstalled Zwift and companion app, deleted Zwift preference files etc.

Have switched to using Zwift on iPhone and plugging into a monitor - works as expected that way, though, this is far from ideal, and in order to see my trainer in “Controllable”, I first have to select it under “Cadence”, then the trainer will display under “Controllable”, then I go back to “Cadence” and switch it to my Stages Cadence/Power meter. I’ve had to do this even prior to the latest update, and for several months.

After the update, on my MacBook, in order to connect my trainer, I need to toggle back and forth between using “Built in Bluetooth” and “Use Companion App” several times until I’m able to see and select the trainer.

Very frustrating that I’ve had to spend so much time on workarounds and that it now isn’t working as expected at all on my MacBook Pro. Really hoping this all gets addressed and soon.

Seriously this is crazy. What is the point of these forums if there is no fix. If I run my ATV and use companion app there is no change in resistance. Works fine when I use my Swift ap on phone and screen mirror. This problem came up about a week ago. Could somebody translate these forums into simple Q&A, wading through all this crap is a nightmare.

1 Like

Similar experience here. Using a wahoo kickr core and a pc running windows 10. Also have a hr monitor and all connected via Bluetooth. Exact same setup that worked perfectly before the summer.

SIM mode…… seems there’s a delay between the screen and the trainer resistance. Low resistance going uphill to start with, then the hills resistance kicks in and stays high going back downhill. Annoying but not too bad when free riding but really bad with a group. I’m putting in different efforts to others so either fall behind or run ahead.

ERG mode…… same delay as above but the impact is worse. For an easy effort following a hard effort the resistance is still high. The only way to lower the power is to reduce cadence which only increases resistance further. It gets so hard I cannot physically turn the cracks when ERG is looking for 150 W.

Raised the issue with zwift and was directed here. Seems they’re working on it which is good…. But this isn’t what we’re paying for.

Hope this gets sorted quickly