ERG Mode Résistance delay

Hi, I’m using Wahoo Kickr 2017 latest Firmware with IPAd Air2 (IPad OS 13.2.2) and latest Zwift Version.
Since around the last 4 Updates I have a problem in ERG Mode.
The Résistance changes in ERG workouts are coming delayed. That means for example when the workout says I should ride with 200W and the resistance should increase to 300W, than I’m continuing with 200W. Around one minute later the power increases than to 300W ( when the workout is already in another step e.g, back to 200W.

2 days ago during a workout all was fine. But today I had the same problems again.
I managed to complete the whole workout but during the whole workout I had a constant delay of around 1 minute ( so I got nearly no stars during the workout).
I noticed this time that my workout started with a small issue. At the beginning of the warm up phase the resistant was much to hard. I couldn’t paddle. Zwift recognizes that an deactivates the ERG Mode temporarily. I could paddle afterwards and the ERG Mode was reactivated. This took around 1 minute and I assume this is exactly the 1 Minute Delay I had afterwards during the whole workout. So Zwift is 1 minute ahead of the Kickr Resistance.

1 Like

Have experienced the exact same issues but with a diff trainer “Direto X”.

Same problem here and I am using a kickr core. In the middle of a workout, the resistance seemed to get stuck at a high power from the previous set even when the screen is showing a low power phase. Happened multiple times

1 Like

I’m having the same issue with my iPad 2017 and Kickr 2017. I usually use Macbook with ANT+ dongle, but switched over to my iPad and the power transitions are greatly delayed during a workout. Sometimes it will take a over a minute or more and sometimes even close to 2 minutes before the resistance “catches” up the proper wattage. I had to quit and go back to the Macbook as it really hampers the workout

Same here, delayed resistance and cannot complete a training session properly. Very annoying Zwift! I have the Kickr 4 (latest firmware update) and Windows 10 running Zwift (latest update).

Unfortunately the issue still exists with 1.0.43784

Still exists with 1.0.43801

I’ve the same issue on Mac OS with Wahoo Kickr 2018

I’m having this exact same issue on the Apple TV. Just started this week for me, in this case after I upgraded the Kickr firmware to transmit cadence.

At the start of the warmup the trainer went into some high resistance mode, had to disable and re-enable erg. After that, the delays between an interval and the trainer reacting started off at 30s and reached 75s by the end of the workout.

What’s the solve?

I am having this issue with Apple TV + iOS Companion on iPhone 7 + Kickr Core. Today I did a 2 hour workout and the delay seems to scale with time, so that by the end of the workout the changes were happening almost 7 minutes behind. I didn’t get many stars :wink:

I just experienced the same delays and came here to see if I was the only one… AppleTV + Companion on Android + Wahoo Kickr 2018 (latest firmware).

With the latest Update for IOS (1.0.44575) it seems to work again

I seem to have no issues when I do not interact with other Zwifters or hit the menu screen. Otherwise I encounter these problems.

Similar problems here, on tacx vortex and android. Really frustrating - cadence and power are all over the place

I have the same problem. Tacx Smart Neo2 + MacOS desktop application 1.0.46903

I’m having the same issue. ERG mode in a workout seems to be about 1 interval behind. Extremely annoying. I’m running a brand new Kickr Core and connecting to Zwift on a Windows 10 laptop over bluetooth. I also use the companion app on my android phone, if that helps with troubleshooting at all.

Sounds like it could possibly be lag from the Bluetooth connection and/or interference. Do you have access to an ANT+ dongle? That would let you test if the same lag is present on that communication protocol. If it isn’t then it’s 100% something with the Bluetooth connection.

I am running a Tacx Neo 2 through ANT+ to a new Windows 10 laptop and have started experiencing this issue about 4 weeks ago. It’s inconsistent (doesn’t happen for every interval) but still quite annoying. I have not been able to remedy it by trying the various ANT+ interference work-arounds. Anyone have any luck with a solution? I emailed Zwift support on this as well but have not heard back.

Same error at the workouts intervals and Race events…
Smart trainer: Wahoo kickr core firmware: 1.0.12
Game version: 1.0.48638
Launcher version: 1.0.23

Anyone has the same issue about the delay?