ERG mode workout does not work

Hello dear Zwifters.
I recently had a problem with my woukouts.
First of all, my setup.

  • Wahoo Kickr Core
  • Apple TV 4K
  • Wahoo chest strap
  • Edge 1030 plus (is used for extra recording)

so now my problem.

Start a workout in ERG mode at 5 min @ 170 watts.
everything works. after 5 minutes the next block comes e.g. 250 watts for 1 minute.

Unfortunately, he does not take over the mudflats. it just stays at 170 watts.

Today I tried to recalibrate. before everything was completely de-energized.
Strangely, it worked up to a longer block in the middle of the workout.
I had to 15 min @ 270 watts.
after 15 minutes he did not take over the watts from the next block again.

Do you have a possibility to fix the problem?

Best regards

Hello,
I am having the same issue since yesterday. And also a friend of mine but for even longer.

I did a spindown and there have been no changes concerning the setup.

The kickr is not adapting to the new wattage demanded by the zwift workout. Even when you try disabling ERG mode via companion app it takes like 20 seconds to actually do so.
However, this issue seems to be temporary. If you keep riding everything goes back to normal after a few minutes. Nonetheless, it prevents successfull completion of a workout if it occurs.

The problem seems to be the communication from zwift to the trainer, not the other way around. So I hope this will be fixed!!!