ERG troubles w/ latest Kickr firmware update?

Anyone having erg workout issues since recent Kickr17 firmware update (regular kickr, not Snap)? Losing erg reactivity, etc. I’m on Zwift for Apple TV, connecting devices via Zwift Mobile Link



I tried ERG mode one time for my FTP test and I do not ever want to use it again.

On the other hand, I’ve ridden hundreds of miles in sim mode with my KickR and I love every bit of it.

I do a spin down every other day in the Wahoo utility app.

Alan, I had a problem doing an FTP test in ERG mode. When the FTP internval started, the Kickr would only allow 110 watts max. I restarted, did a spindown, turned off ERG mode and it worked ok.

Separately, I’m also experiencing power fluctuations in any mode. Impossible to hold power at say 150 watts - jumps around from 100 to 200 and I fail all workout segments because its so erratic. Seems many people have had this over the years and Zwift chalks it up to sensor dropout. I don’t think it is because my power never goes to zero - just up and down in a range +/- 50 watts. I think either the Mac driver or the software is not sampling fast enough.

Which problem are you having?

1 Like

Thanks for the replies, all.  I think I figured out my issue.  I had a lot of apps open on my phone yesterday morning, and I think one of them was trying to hijack bluetooth in the background, as ERG mode kept cutting out on my workout.  Anyway, I tried it again this morning, quitting all iPhone apps except for Mobile Link and all was well again.


I have been experiencing a problem during the FTP test using my Kickr. Even if I gear completely down and crank up my cadence to 115 rpm or higher, I cannot achieve more than about 150W. I use my iPhone 7plus with Bluetooth link to the Kickr. I tried the FTP twice, a couple of days apart with the same results each time. I have a trouble ticket in to Wahoo but haven’t heard anything back yet.