power fluctuating in erg mode


(michael waters) #1

Is anyone experiencing this problem…since the latest Zwift upgrade today, my Wahoo Kickr doesn’t seem to be able to be consistently controlled in erg mode. The wattage is all over the place. I’ve worked my way through all the generic Zwift trouble shooting guidelines to no avail. All firmware is updated. The ant+ usb seems to connect. No new devices in the vicinity to cause interference. I’m at wits end.


(Bruno Bedard) #2

I noticed it also with zpower…


(Chris Carney) #3

I’ve had all sorts of issues in the last week or so. I’m not 100% sure of the problem yet, but I have had drop outs / loss of connectivity via ZML with my Kickr. 

One thing I’ve noticed is that the Bluetooth signal from my Kickr is very weak (according to the Wahoo Utility app) & I’m wondering if this has anything to do with it.

The weakness of the kickr BT connection and some drop-outs from my new Vector 3 pedals are making life a bit tricky at the moment to get a decent ride. Power match doesnt seem to be working well…

 


(Terry Thomson) #4

I had the same thing happen this weekend.  Although Zwift won’t admit it I think the update did something to ANT+  If I turn that off and go straight BT between my Macbook and Kickr I am OK.  I never had a problem before this weekend.

 


(Reed Markley) #5

I have had this problem both yesterday-3/7/2018 and today-3/8/2018. In the past, in ERG mode and performing a workout, the required power held quite constant ± a couple of watts, unless I really did something weird. Then it just gave me the red letter warning about power. Yesterday and today, power was all over the place. ± 10 or 20 watt excursions from that being called for. Seemed to always come back to the required level, but not as quickly as previously.

When I use the Zwiftalizer-the Zwift log file analyzer, my ANT+ connections to all devices-Kickr, cadence and HRM - during the ride are solid. No change about strength in the last few days. I wonder if the ERG mode has been messed with? My “Use ERG mode” button is pressed.

I just did a Spin Down using Zwift rather than the Kickr Wahoo Utility App. We will see tomorrow if that has an effect.

I noticed that, on the Spin Down page of the Utility App, that, on the blue button below the blue Start Spindown button, that the label was “Disable ERG Power Smoothing” was showing. I assume this means the power smoothing is enabled, since if you press the button you see the message “Enable ERG Power Smoothing”. I will run some tests tomorrow to see if this has any effect on power stability.


(michael waters) #6

Yes. No solution to my woes unfortunately, despite working through the Zwift check list as per instructions. I suspect that the latest update led to some ant+ connectivity issues, so will hopefully ‘spontaneously’ rectify after the next upgrade, fingers crossed


(Reed Markley) #7

I received Zwift update today 3/9/2018. prior to starting a workout. All power levels behaved as normal. Excursions of only ± 1 or 2 watts. Yesterday, excursions were ±10 or 20 watts. Hopefully the problem has be repaired.