Zwift/wahoo kickr not holding power during structured workouts


(William Mabus) #1

Hello all. So I am having issues with my power not working correctly during structured workouts recently. The issue may be my wahoo but I figured this might be a decent start. So this is what I am seeing. I used to be able to set a power number for a structured workout and my zwift/the kickr would hold it super steady, within a watt or two. Now my kickr is certainly working in erg mode but the power is much less accurate. I am using a pair of saris pedals for cadence so maybe they are fighting each other. Also using an ant dongle with a minimum standard pc, but I noticed this on my iPhone as well when I tried it on the phone. Any idea what I can do, as sometimes it is really bad and the erg mode drops so low I cannot even come close to hitting the power numbers.


(Lin Alan) #2

On the assumption ‘Saris pedals’ refers to the Powertap P1/P2 pedals?

When pairing your devices, make sure of the following:

  • Power – Kickr or Powertap pedals
  • Controllable trainer – Kickr
  • Cadence – Powertap pedals

Double check the pairing screen before you proceed. Sometimes when you pair/unpair one device, Zwift will unpair something else.

Is the ANT+ dongle directly inserted into your PC or connected via a USB extension cable? If you don’t have a USB extension cable, I highly recommend getting one and then placing the dongle down under your Kickr.


(William Mabus) #3

I do have a dongle and on an extension but this issue is prevelant with both my iPhone on Bluetooth and also with my ant+, which leads me to believe something else is happening.

Thanks for the feedback BTW.


(Lin Alan) #4

Did the problem start with a recent update of Zwift itself (i.e., Zwift broke something)?

You mentioned that “maybe they are fighting each other”. I have had this happen when I am using TrainerRoad in ERG mode while simultaneously running Zwift. Why? Because I forgot to unpair the controllable trainer in Zwift. As a result, both TR and Zwift are fighting over control. You wouldn’t happen to be doing something like this ??


(Lin Alan) #5

One more thing…

I forget if the Kickr gives you more than one ANT+ option when pairing. But if it does, make sure you select the ANT+ FE-C option.


(William Mabus) #6

I would say this started happening within the past couple of weeks, and it is noticeable in Bluetooth mode with my IPhone and also on the PC with the Ant+ dongle. Maybe I am asking it to do something it should not be able to do. So…

This is what I thought it was doing and what I want it to do. I have a structured workout that expects me to hold a power number for a set amount of time. So. Imagine a cruise interval. Historically the trainer would ramp up to that power number and hold tight there, or be within a couple points of it. So if I was supposed to old 243, it would be able to sit at 242 or 243 for about 15 minutes consistently. Right now, when my interval starts, the trainer definitely gets more difficult as if erg mode is working, but my actual power output is usually bouncing 10-25 watts higher or lower. I don’t recall this being and issue before. I remember doing workouts that were spot on to the number recently.


(Lin Alan) #7

In ERG mode, as long as your cadence is steady, the power should be quite steady as well since the system does not have to adjust the resistance as often once it settles in. If your cadence is not smooth/steady, then you should expect to see some up/down variation in the wattage as the system is constantly having to adjust the resistance to get you to the power target.

Are you using the workout mode in Zwift?


(William Mabus) #8

When you say workout mode…?.. I think so. I have build a few workouts and used them in the past without these issues. Things are a little different in a new firmware, but I think I am in the workout. For instance one of the settings is a “warm up” with the power increase gradually, and during the warm up I cannot get it to increase the way it had before, or in my opinion should.


(William Mabus) #9

Ok. I went back out to my shop/trainer to check all this one more time. I noticed looking at the pairing setups, that my power setup is correct on this with the FE-C device, but that the controllable paired device in the lower right corner was off. The detail was correct but it was missing the FE-C stuff. I tried another warm up and it was a bit better but still noticeably not under the proper control.

I honestly think something may be wrong in my trainer. I have been seeing the red Ant+ light flickering some, so not sure if that may be my issue or not. That said, it does it off my phone with the Bluetooth connection. I am truly frustrated. The weather sucks and my trainer is setup is letting me down.


(William Mabus) #10

Well… I might be an idiot but here goes. I think under a new update from Wahoo my kickr went away from the power smoothing mode. I have not tried it that way yet but certainly will tomorrow. If this was all it was I will be ticked.


(Andreas Grønneng Hjelme) #11

Let us know! I have the same issue. Workouts used to give me watts within 1 or 2 of target, but now it fluctates by ±30, even though erg-mode certainly works. Kickr Snap.


(William Mabus) #12

Well, that wasn’t it. I think it is actually something on the Wahoo side. I set the power smoothing on my phone as the Zwift settings don’t appear to show that. Moral of the a story is I think I could tell it was trying but was still not working properly. Still consistently doing the same thing both on my iPhone and on my PC. Someone has a video on YouTube about the smoothing thing. It suggests that you set it and leave it on the iPhone app. In the video you could see the power profile on Zwift with, and without smoothing. This looked similar to what I am seeing. Anyway, I went to set the smoothing on my iPhone and then do a structurede workout in zwift with ant+ and the same issues came up. I then killed it all, and went back to doing my intervals with my iPhone in the wahoo app by just using resistance and my own efforts etc. Soooo. Considering how I have had issues with wahoo and some initial releases on a snap I am a bit dubious it is a wahoo issue. I will report back.


(Lin Alan) #13

The smoothing is a cosmetic thing. If enabled, it artificially smoothes the power data making it look damn near flat or extremely pretty. That is not reality. Your power output is not that smooth/pretty. A good analogy would be looking at 3s power and comparing it to 30s power during one of your intervals.

When you say it’s bouncing 10-25 watts high/low, where are you seeing/viewing this? If you’re looking at Zwift, I am pretty sure that the default is 3s w/the other option being instantaneous. Maybe you should check this setting has been changed to instantaneous. Again, while instantaneous will be jumpier than 3s, 3s is still quite jumpy.


(Mel Rooney) #14

I’m having the same the same issue, when I do a structured workout the ERG mode doesn’t work, sometimes it’ll kick in but then the watts are all over the place…infuriating.

I noticed the change after I’d had an update from zwift, I was using a tacx flux which broke ( again) so I bought an elite drivo…thought this might fix the issues but no difference. I have reported it to zwift and I’ve done everything they suggested, so far.

It maybe coincidence that it was after the upgrade etc but I cannot understand what has happened and changing smart trainers hasn’t fixed the problem. It’s real shame, I cannot use zwift for structured training now and if it doesn’t get sorted soon i might as well cancel my subscription with zwift.


(William Mabus) #15

Lin. I have it on 3s. When I saw bouncing, it is usauly 10 watts higher and lower. And its a pretty instantaneous bounce. I am quite certain it was not doing this when it appeared to be working properly.


(Mel Rooney) #16

My watts spike is huge, it can be between 20 to 70 watts up and down, and will also it will suddenly tell me to pedal harder when i’ve not changed my pedal stroke and the watts will drop massively. The point for me is irrelevant of the watts the only way I really get resistance is through changing gears which is obviously incorrect…The ERG is not working at all :frowning:


(William Mabus) #17

Sounds like I am not the only one battling this.

Talked to Wahoo about this and walked them through my settings. I talked about the fact that my settings on Wahoo keep getting changed when I log into Zwift and they said this is not normal. They think it is on the zwift side. I filed formal ticket with Zwift but I too am at a point where using zwift is now not practical for structured workouts. I haven’t tried to use the group ride features as this is not how I normally use zwift. Regardless of whether this is a IT feature at my house, or if this is a zwift/wahoo glitch, I am disappointed about this given the time of year. I am also dubious as my son has been having the same issues during workouts with his iPhone.


(Lin Alan) #18

Have you tried using the Wahoo app on your phone to control your Kickr? This would help you determine if the problem is the Kickr or Zwift. It’s been a while since I owned a Kickr, but if I remember correctly you should be able should have a couple options to do some testing. You could pair your head unit via ANT+ to verify numbers and record data simultaneously as well.

  • Using the app, set a wattage and pedal. If you change cadence, does the Kickr respond and keep your power steady? Is it smooth? Is it jumping all over the place?
  • There should also be an option to control the Kickr w/an ANT+ power meter (i.e., your pedals). You will need to manually enter the ANT+ id of the pedals. The Kickr should then be able to pair directly with the pedals via ANT+. Now when you ride, the Kickr will use the power from your pedals to control the resistance of the Kickr. Go back to the workout page (?). I think the power icon will look different to signify it’s using your pedals. Anyway, set a wattage and pedal. Working? Smooth? Jumpy?

Again, it has been a while since I owned a Kickr. As such, I am a bit fuzzy on the details but think the above should point you in the right direction.

I would record the data with my Garmin to have some graphs and data for comparison.


(William Mabus) #19

Lin. Thanks for chiming in. Yes. I did the entire workout yesterday in my wahoo app after the drop issues in Zwift. It worked as it should then.

I have sort of hit my limit on ideas. I am curious to see what Zwift has to say.

RickM


(Lin Alan) #20

If all worked as expected using the Wahoo app or another app, then I too would point the finger at Zwift. There were several updates during December. Perhaps one of them broke something. Then again, Bluetooth issues, resistance, and ERG issues existed long before December. Another thing is that you mentioned this was also a problem when using ANT+. Usually, ANT+ is a reliable workaround if Bluetooth is not working properly, especially when using a USB extension cable. I do not use the Zwift workout mode, but suspect that perhaps something is broken when in that mode.

How is the Kickr resistance if you are free riding around in Zwift? Does the resistance adjust accordingly to the in game gradients?

In the meantime, you could use your phone to do your workouts, pairing via Bluetooth. And via ANT+ pair to Zwift to get the visual distraction, mileage, etc…

p.s… I assume you have verified that your Zwift versions are all the latest and greatest ?