WAHOO KICKR CORE - Increase / Decrease not in line with resistance

Since a couple of weeks I have a strange issue when training on Zwift with my Kickr Core. Whenever I climb up, the resistance of the smart trainer does not reflect the change in resistance. The resistance change then comes later which could lead to me ride down on the screen but having the hard resistance of riding upwards.
This also happened when doing a workout using the ERG mode; when the wattage was supposed to change it did not on time. Somehow it did like a minute too late.

Can you help as this is really anoying?

I’m running into the same issue.

First time using erg mode with Zwift (though I’ve used erg mode before in other apps without an issue).

There is a major lag between Zwift and the Wahoo Kickr Core, for example, it takes about 1m30s to update the resistance. So the display screen is almost always out of sync with whatever resistance the Kickr core is applying. The big issue then is that you’ll be trying to ride along at the requested resistance and the trainer will be trying to up or lower resistance based on an out of phase target. This leads to some rather odd situations, e.g. being told to lower power but the trainer keeps increasing power.

Wahoo Kickr Core firmware: v1.1.1 (latest)
Zwift version: 1.0.78621 (1.0.25 launcher)

If you search Kickr firmware issues then you’ll find another post, could be related to this issue (can’t post links here).

But is there a solution?

Well, I’ve just tried downgrading firmware on Wahoo Core to old version and the delayed erg-mode power target issue still happens, so doesn’t look like it.

Hi @Gareth_Simons and @Nico_Malena

What devices are you using to run Zwift, have you tried testing the trainer in another app to see if you have a similar problem, and have you tried contacting Wahoo support?

I haven’t seen the same problem with my Kickr Core on Zwift so it might be worth contacting Wahoo.

I am using an iPad, which worked quite fine for about a year now.
But since I made the latest Zwift App Upgrade on it, I have that issue.
I will check tomorrow if the issue also occurs if I use another device.

I am also having the same problem. Running Zwift on an Apple TV. I originally thought it was a calibration issue, but when I try to do a spindown it sometimes times out while attempting to connect to the trainer or the trainer keeps adjusting resistance to hold me around 25kph.

I had the same issue after upgrading Kickr Core firmware to 1.1.1 - I downgraded it and all is back to normal. However I think the real solution must be using latest firmware and “resetting” the trainer in Zwift - Wahoo must be shipping/selling new units with the latest firmware.

Instructions on how to downgrade in this thread about the issue: wahoo-kickr-core-1-1-1-firmware-issues/551758

Just flagging that the same issue exists in the latest version of Zwift app on MacOS and iOS companion app. Given up trying to figure out what combination of devices on what combination of versions works. :man_shrugging:

I am experiencing the major delay issue as well. Everything has been updated and there is still about a 90 second to 2-minute delay between what is on the screen in Zwift and my kick and climb. Has anyone been able to find a fix for this?

If your trainer is running the latest firmware it’s a know problem, you need to downgrade to an older version 1.0.13, if you search in here there are a few guides on how to downgrade the firmware

1 Like

I experience this delay too, and this lag seems to increase with the length of the session. i described it in this post: “funny-resistance-wahoo-kickr”

I have a KICKR18 and i run Zwift on Macbook.

my issue started occuring a good few months back. could be around the time the thread started above (July/Aug). will try to downgrade to old firmware.
But is this then a Wahoo issue or a Zwift app issues?

I am having the same issue with my wahoo Kickr core. I am just about done with the hole Wahoo experience!