Unable to download a ride - and it didn't auto-upload [July 2021] [SOLVED]

@Wouter_Linssen

My take, reading on here and from trying to salvage the .fit files is that it’s not possible to do this.

I’m hoping Zwift HQ may have the files somewhere in the depths that we may at some point be able to access. But that hope is dwindling now.

Sorry about your lost rides. There are many 1000’s of us out here using ATV who are in the same situation.

Some may have left Zwift already. I’m considering that as an option but if truth be told, when Zwift is working it ticks all the boxes for me. I like the Zwift community and I’m not sure what other options available would do the same for me.

1 Like

That’s such a bummer. To be sure, after you restart the app to join your event, you’re making sure to not pedal at all before clicking “join event” so that the timer reads 0:00, correct? From what I understand, even just a few seconds of time being ticked on the timer before clicking “join event” will screw up the .fit file for the event.

Thanks for posting such detailed instructions.

I follows these steps exactly and it worked a treat, all data recorded and sent to Strava okay.

1 Like

Getting beyond the joke now. Followed all the cludge instructions, still no joy. I give up :man_shrugging:

Everything was okay yesterday. Today, I rode two group rides. The first saved the data with no problem. The second showed 0.01km distance and other completely inaccurate information.

THERE IS STILL A PROBLEM.

Version 1.15.1 fixes this issue, and went live ~45 minutes ago.

Please verify that you’re on 1.15.1 (1.0.75994) as the app launches.

2 Likes

@Chip_Hoyt
I looked at your ride today on TickTock and you’re still on v 1.15.0. Please visit the App Store and make sure your AppleTV is on 1.15.1

No fix for historical rides that did kit upload?

2 Likes

Is a fix being worked on for historic rides, or are these lost?

1 Like

@Craig_Roberts_PLCC and @Petoz
The only way that FIT files can upload to Zwift’s servers is through a successful ending of a session. I hate to break the bad news, but there’s no way to retroactively upload sessions.

Ugh. I figured as much. No worries, this will just have to be my motivation for riding up Ventop again :slight_smile:

Thanks again for getting the patch out!

@shooj They were uploaded to the Zwift servers, and, at least for me, even showed up on Zwift Power complete with power and HR breakdowns. They show in the activity lists both in the companion app and the my.zwift.com activity feed, showing distance, ride time, elevation, and calories burned in the feed. But when you go into the activity itself in the companion app, you get “Activity details could not be loaded” showing all that basic info, but no photos, route info, or power/hr graphs. On the website, you get basically a blank page (header and footer only). Fit files downloaded from the website are broken, tho, as far as Strava is concerned.

So something is getting uploaded, it’s just broken. I guess the question is whether whatever is broken in them is fixable.

7 Likes

My race ride managed to upload correctly to zwift power, however it used the warm up details on the companion app. I’ve checked zwift power again a few mins ago and it’s now changed the statistics to the warm up ride ie wrong power /hr details etc. Very very disappointing, appreciate tech things go wrong but losing rides is really frustrating especially if you’ve done an effort

1 Like

My ride uploaded ok. Had to manually update ATV to new version beforehand. Did not warm up but went straight to event

Just need to fix the historical rides.

This happened to me last night. Fine to now update the version, but how do I u[pload last night’s ride when the FIT file seems to be empty (1kb), yet the Zwift ride history definitely shows I did the ride and the time - so the information must be stored somewhere, how do I access it and get it into Strava?

3 Likes

I have the same exact situation. I did a really hard race and I see the activity and details, but when I click on the activity to obtain the FIT file, that page is blank. It’s exactly like Trey is saying. Does Zwift have a fix? All of the ride information is there!

I’m not too sure what procedure you did not making it work @Kevin_Bishop

I have just done a double race back to back Aussie Crit Crusher 1 and 2. Everything uploaded

And thats what I did.

Warm up with Brevet and 10 min before crit 1 start. Save the warm up and press save after taking the data from the captured photo :joy:. Go on log on screen. Force quit (double click screen button on ATV remote) and flip the app up.

I also wait for 10 second and check something on the other app.

Then I join Zwift. Select any world. Join the event straight away. RACE … got :1st_place_medal::sweat_smile:. Then soft pedal for a 30 seconds. Quit and save photos. Got on log on screen. For quit.

I was checking the Olympic TT result for a minute.

Then I log on for race 2. This time I try to pedal 20 seconds before joining the Crit race 2 in NYC. RACE … got :1st_place_medal::grin: again. Pedal for 30 seconds to cool down. Save.

Everything on Zwift screen and on Strava :+1:t3:

Edit just saw the update from @shooj

Now I update the app.

1 Like

Just in case anyone misses the update in the original post at the top - Zwift claim that this is fixed as of this morning’s release. Not tested it yet myself but fingers crossed…

1 Like

Updates appeared for both apps today for me. Seems to be working now however issue of yesterday’s fit file still in progress and using data from the previous ride doesn’t look like it’s going to be fixable.

1 Like

The update worked for me

1 Like