Unable to download a ride - and it didn't auto-upload [July 2021] [SOLVED]

So it seems a week later and still no solution. I am having all the same issues as above.

Maybe I’ll just go back to riding IRL where it is free and quit my subscription…

Or I have been considering trying a different platform, this could be the time :wink:


So almost a week since this major bug affecting thousands of users was reported, and no action from Zwift still?

The fact that Zwift developers and management are getting to the end of the day and going home leaving this unresolved day after day is just staggering. It would take literally minutes to roll back this completely failed release. Any other competent tech company would have done this on day one.

Zwift seems to be in complete denial and simply ignoring the chaos this is causing. The zwift status page lists “No incidents reported” for the last 7 days, which is just a joke. This is management failure at Zwift, pure and simple.


I started using RGT with satisfaction, and it’s free too. I will not renew Zwift anymore, what a shame!

No joining in different world does not affect me

I can’t keep posting what I found working for 4-5 group rides and races now.

Just force quit the zwift app EVERYTIME you quit the game, even you discarded not saving the ride.

I also tend to warm up. Save. Force quit. Log in. Select any world. Join event/race straight away without pedalling. And race and save. IT WORKS!

Ride On


That doesn’t work for us unfortunately, Stephen. My wife and I have lost rides in the last couple of days and then read about quitting the app after warm up and restarting for the event. We both rode today and both events didn’t sync to Strava and no fit file available on the Zwift website, although the main page displays a photo and basic details of the ride.

Today my wife’s ride was the WTRL Classics ride and not only are there no details on Strava but no results yet showing on the WTRL website, so I hope everyone’s rides haven’t been lost! All the power data is showing up on Zwiftpower, though, which is something, I suppose.

Almost waiting a week now for my Ven-Top meeting to be uploaded. I understand that there can be problems, but the communication about the issue is horrible as well. Does anyone have news on the corrupted files and if there will be a way to recover them?

happened to me 3 times now. Very disappointing and annoyed. Nothing from Zwift at all about the issue?

I’m another with this type of issue. I’ve completed two rides, both over an hour long, but the map in Zwift and the uploads to Strava and Garmin only show 5-6 seconds.


Yup still exists on ATV. I even read the zwiftinsider article last night, but when I crawled to the trainer this morning for Zwift Classics Race totally forgot about the workaround. Ended up with fit file showing 3 seconds of data for the race, but I still have my 6 minute warm up saved. Yay. Tried downloading the fit file from zwift and zwiftpower, since they show the right time, distance, power, but when I reupload fit file still only shows 3s worth of data.

1 Like

That sucks!! My work around is to go directly to event once I log in and warm up in the pens for now.


My take, reading on here and from trying to salvage the .fit files is that it’s not possible to do this.

I’m hoping Zwift HQ may have the files somewhere in the depths that we may at some point be able to access. But that hope is dwindling now.

Sorry about your lost rides. There are many 1000’s of us out here using ATV who are in the same situation.

Some may have left Zwift already. I’m considering that as an option but if truth be told, when Zwift is working it ticks all the boxes for me. I like the Zwift community and I’m not sure what other options available would do the same for me.

1 Like

That’s such a bummer. To be sure, after you restart the app to join your event, you’re making sure to not pedal at all before clicking “join event” so that the timer reads 0:00, correct? From what I understand, even just a few seconds of time being ticked on the timer before clicking “join event” will screw up the .fit file for the event.

Thanks for posting such detailed instructions.

I follows these steps exactly and it worked a treat, all data recorded and sent to Strava okay.

1 Like

Getting beyond the joke now. Followed all the cludge instructions, still no joy. I give up :man_shrugging:

Everything was okay yesterday. Today, I rode two group rides. The first saved the data with no problem. The second showed 0.01km distance and other completely inaccurate information.


Version 1.15.1 fixes this issue, and went live ~45 minutes ago.

Please verify that you’re on 1.15.1 (1.0.75994) as the app launches.


I looked at your ride today on TickTock and you’re still on v 1.15.0. Please visit the App Store and make sure your AppleTV is on 1.15.1

No fix for historical rides that did kit upload?


Is a fix being worked on for historic rides, or are these lost?

1 Like

@Craig_Roberts_PLCC and @Petoz
The only way that FIT files can upload to Zwift’s servers is through a successful ending of a session. I hate to break the bad news, but there’s no way to retroactively upload sessions.