Training Peaks workouts went away [Nov 2022] [1.31] [SOLVED]

I use Mac OS - they are not showing up as of this update

Yes. I did the same and still nothing.

Thanks for reporting back everyone. We also are seeing this impacting PC and macOS platforms.

For now - if you are able to use a smartphone / tablet / AppleTV to Zwift, it seems that Training Peaks workouts are showing up on those platforms.

Stay tuned - we’ll update this thread as we make progress towards a fix.

3 Likes

I tried the disconnect/reconnect accounts but no luck.
The interesting part to this is that even though TrainingPeaks workouts do not show up in the menu, when you complete a Zwift workout it does upload to TrainingPeaks. So the connection remains

4 Likes

Yes, exactly the same issue. 7 weeks into a 12 week plan and all progress has been lost.

Highly frustrating having been diligently following the plan and tracking the numbers

Correct. I do not use TP. I’m talking about the native Zwift Training plans. In my case, the FTP Builder course that is built into Zwift.

@shooj What about us who aren’t using TP, and are using the training programs built into Zwift? (I’m was on the FTP Builder, and I’ve heard from others who were doing Zwift programs that have lost all progress.)

The split in this ticket into Training Peaks specific issues is concerning, because that isn’t my issue at all.

Shooj has created the “lost training plan” thread here …

Hi @Aaron_Norris
That is a different issue. You can keep tabs on progress on this other thread

@shooj Thank you for that link. I was confused why my comments had been split off and lumped in with the TP issues, when it was unrelated.

MacOS - unable to see TP workouts in the dropdown
Were visible yesterday pre-patch

Mac OS; unable to see TP workouts. Just chiming in here per support request.

1 Like

I had the same issue after the 1.31 update on a Windows 11 laptop. I tried uninstalling, deleting all related Zwift files on the computer I could find, and reinstalled, still no TrainingPeaks workouts. I also disconnected/reconnected TrainingPeaks from Zwift Companion app. TrainingPeaks workouts show up just fine on Android phone. Also, and this may be a hint for the Zwift support team, when I installed Zwift on a laptop that previously never had my Zwift account on it, the TrainingPeaks WOs are available on that laptop.

Hope the Zwift team can get this fixed up quickly.

My wife and I are both having this problem on a Windows PC.

To be more specific, the day before yesterday I was able to see my TrainingPeaks workouts in Zwift. Last night I applied an update, and could no longer see them in Zwift. My wife had the same issue on her account on the same PC. When we’re done with the workouts they get loaded to Training Peaks, so it just seems a matter of pre-ride workouts making it to the training library in Zwift.

I tried disconnecting and re-establishing the connection between Zwift & TP, as well as uninstalling and re-installing Zwift. The problem remains.

On Windows 10 all my Build Me Up workouts (on week 6) were gone after the update. I switched to AppleTV and my previous workouts/progress are available. If you have the option to switch from Mac or Windows to AppleTV it may help.

The heading for “Training Peaks Workouts also went away for us”. Mac OS

1 Like

Visible on iPadOS but not on macOS.

1 Like

Windows 10, had finished 25/27, now resetted to 0.

I manually imported them and that worked. Bit of a faff but at least you can do your training