Looks like the connection to Training Peaks is broken today [March 2024]

Logged in to zwift this morning, and my TP workout were not visible in the app. I have tried disconnecting and reconnecting TP and zwift but that did not work.

This worked yesterday but today’s workout is not present. Already tried to remove/re-add without success. This was also reported in Zwift reddit

Same issue here - started this morning/worked fine yesterday

1 Like

Hey there !

Is anybody having probleme with their training peaks scheduled work out ? Mine was showing and working perfectly 3 days ago when I did a new FTP test, but now I can’t seem to be able to see any workouts for training peaks on my zwift app.

Thanks !

Same here ! I tried moving around some workout to see if it was today’s specific work out creating the probleme. But nothing seems to show.

Was working perfectly 2 days ago

Zwift won’t pick up the training peaks today?

Nope. Still not working

I tried everything and kept getting yesterday’s Training Peaks workout pop up. I finally unpaired yesterday’s TP workout and moved today’s workout into yesterday’s spot. That worked so I’m thinking something is screwed up with what day Zwift thinks it is?

1 Like

Anyone’s TrainingPeaks workouts disappear after Daylight savings? I’ve disconnected and reconnected 3 times without success.

I am having the same problem. Today’s workout is not showing up but yesterday’s is. I took today’s workout and placed it on yesterday in TrainingPeaks and now it is showing in Zwift.

It’s springtime in Zwift




Same with me - yesterday’s is still there - which generally never happens so the connection itself is broken. It looks like this happens every March…

My workout from TrainingPeaks did not sync with Zwift today. I disconnected and reconnected Zwift from TrainingPeaks without success. Anyone else experiencing this today?

Same issue. Completed all known troubleshooting techniques a couple times (app updates, closing apps on all devices, disconnecting connection between the apps). No workie. It’s the weekend and a Sunday, and Zwift probably doesn’t have 24/7 support staff. Hopefully they fix or provide an update first thing in the morning.

1 Like

Same issue here! I did everything (app updates, closing apps on all devices, disconnecting connection between the apps, reinstall apps) and didn’t work it. Let’s see if they solve the problem today!

Contacted Zwift Support. They are aware of and are working on this. No estimated time to repair given.

1 Like

I continue to have issues with Training Peaks not syncing with Zwift and not showing in the custom workout folder. I understand you should only see that day’s workout and the workout needs to be power based. Sometimes it will show, for example, the previous day’s workout, and actually the previous days workout will be duplicated. I am using the Zwift app/iPad/iOS. I have disconnected and reconnected to TP and uninstalled/reinstalled the app - neither of those options work. This is still an outstanding problem. I hope it gets some attention. TY.

This looks like it has been resolved. When I check Zwift today, the correct workout is there for today so it looks like it’s working again (or at least updated for today - hopefully stays fixed :slight_smile: ).

Though this happens when Daylight Savings Time occurs, for those that are still not seeing your workout, please try the below from our support article:

If you don’t see an expected workout, ensure your time zone in TrainingPeaks matches the local time zone on your device.

If your workout is not showing after trying the above, please try disconnecting TrainingPeaks from your Zwift connections then try re-connecting to see if appears again.

1 Like