Training Peaks Custom Workouts Not Syncing [March 2022]

After the latest update, the “Training Peaks Custom Workouts” Tab on iOS is completely gone for me??

Is this happening to anyone else too?

2 Likes

I have the same issue. Cannot find my Training Peaks workouts in Zwift. I tried to reconnect - but no luck. Something strange with the new update?

1 Like

February 2022 and still having this issue. Gave it a name, done based on distance and %threshold pace, on day of it still doesn’t show up in Zwift.

Same issue for me today. Beyond frustrating. How is this still an issue 2 years later??!!

Hey all - thanks for flagging this up. The syncing between Training Peaks servers and Zwift’s servers isn’t working correctly, and we’re investigating.

We’ll update this thread with progress reports.

2 Likes

UPDATE:
Please try this workaround: Disconnect TrainingPeaks as a third-party connection, then re-connect. This can be done either on your web profile page, or in the Zwift Companion app. Step by step instructions for either method are on our Support Hub.

Please let us know if that restores your missing Training Peaks workouts?

In the meantime - we’re still investigating the root cause of what happened.

2 Likes

Tried doing that twice and it doesn’t work. You guys screwed up. Fix it !!!

They are looking into it already. Tbh, this must’ve been the ONLY thing they have messed up and not gotten it fixed in a year. Give them a break-… I mean seriously.

Hey Shuji, this did not fix the issue on iOS.

Hope the team can fix this soon!

Thanks for all the great work

Does not work for me is annoying that you are not able to sync your workouts from tp

Hi, Is there an update available for this issue? Training Peaks still isn’t syncing workouts. Thanks

Just tried resetting and nothing. No sync. Problem started for me last week. Any updates??

I noticed that my workout didn’t upload yesterday then today none of my TP workouts appeared. When I opened the companion app, somehow I had been disconnected from TP. Closed the companion app and desktop app. Reopened desktop app, and today’s workout was there. Still need to figure out how to upload the data from yesterday

Still an issue today with the newest update to the iOS app. Android / Desktop apps work and pull the workout. Nothing in iOS app.

Another iOS app update (1.24.1(100794)) and still no TrainingPeak workouts. Android (1.24.0(100757)) app and Desktop app are fine and both showing the workout.

May 9 2022. Training peaks not showing in workouts. Have tried disconnecting and connecting both several times!!!

1 Like

Hey Guys!

I can either load my TP workouts…what is going on?? any way to do it manually? this is crazy

Hi, any news on this? still not able to upload TP in Zwift…

Hi all,
I wrote to Zwift. They don’t know!!! But are working on it!!!

Zwift has told me that it is. TP issues, that they had some warning signals…. I have contacted TP