Training Peaks vs Zwift no custom workouts?


Since last week I cannot upload or see any TP custom workouts in Zwift. I done all what I could, restart the app, reconnect, connect app Zwift, TP etc. any idea? Maybe recent update messed something…again ? Thanks, KJ

I’m the same, It was working yesterday with my wife’s account but today nothing!

has there been an update?

Same issue for me, worked two days ago now tried all but get nothing.

Today was also the first time that my Training Peaks planned session didn’t appear in Zwift. I’d seen other people signaling issues on the Forums during the last few weeks, but mine had been working perfectly. Curiously, the two Training Peaks workouts that I did yesterday were still in the Training Peaks folder in Zwift. (Usually only the current day’s workout files appear there.)

My first reaction was to wonder whether this might be connected to Daylight Saving Time having started in my country earlier today, and that there might be some kind of sync issue. Probably not…

A workaround while this gets sorted out: Since I run Zwift on a PC, I was able to open Training Peaks in a browser, select today’s planned workout, export the .zwo file to my PC downloads and then drop it in the Zwift \ Workouts folder in File Explorer. I restarted Zwift and the desired session was then available.

Same issue for me - Training Peaks workouts have always appeared, but today yesterdays workout did.

Removed and re linked TP but made no difference nor did editing what should’ve been todays workout. My bet is the change to BST from GMT to blame?

Same here, was very annoying - just ended up using my head unit instead…

Did all the usual, restarting, unlinking / linking TP etc

Thanks Niku! I am running it on IPad hence not sure how to bait that ?

Hi Klaudiusz – Sorry, I’ve tried just now to find a way to do that on my own iPad (on which I hadn’t run Zwift for a long time), but didn’t come up with a solution. Opening the Training Peaks app on the iPad, I was able to select ‘Export workout file’ for a session, and to choose file type (ZWO), but after clicking on that I couldn’t find any .zwo files on my iPad or on iCloud. :man_shrugging:
It’s frustrating, now that iPadOS has a user-accessible file directory, that we can’t upload files from there to the Zwift App. (Or at least, I don’t think there is a way.) Searching on these Forums and YouTube, there are older postings about syncing an iPad with a Mac in order to accomplish what we are looking to do via iTunes, but if one only has an iPad… I have no idea. Anyone else?

Just as a further general data point on this subject of Training Peaks syncing:
I checked the Training Peaks Custom Workouts in Zwift on my iPad just now, and the session that appeared was the one that was programmed for 26 March and that I completed yesterday, about 15 hours ago. This would suggest that there is a date-related sync issue between Training Peaks and Zwift. I manually deleted that workout from my Training Peaks Custom Workouts folder, logged out of the app and then hard-closed it. I then opened Zwift on the PC that I use when zwifting, and there were no custom workouts available (as would be expected, since today’s my rest day).
I then closed Zwift on the PC. Opening Training Peaks in a browser on the PC, I added a workout for today (just to test the syncing), refreshed Training Peaks in the browser, and then re-opened Zwift on the PC. Lo and behold, the just-added workout appeared in my Training Peaks Custom Workouts folder. So, something is working. If all goes well, when I check in Zwift again tomorrow, the workout programmed for Tues, 28 March will be the only session available in my Training Peaks Custom Workouts folder.

I’m happy to report that my Training Peaks custom workouts are automatically appearing in Zwift when they should, again. I hope others are seeing a return to normal, too.