Training Peaks workouts went away [Nov 2022] [1.31] [SOLVED]

Love the new roads. But the link to TrainingPeaks workouts seems to have stopped working?

1 Like

Any chance on you getting the training peaks linkage fixed?

Same here. I had opened up my companion app and originally it showed there but when it connected with my computer and pulled up the map screen I lost the training plan section. I closed and reopened Zwift a couple of times as well.

1 Like

@Karl_de_Veet I’ve just followed what the “Zwift Ambassador” requested (a fresh install) and it didn’t work. What it did was restore the ability to sign up for a training plan. Thus my current training plan was the one I tired to create to recover my progress.

With chatting with Zwift support, they want my logs. Because of the fresh install procedure, my logs now only cover the new install.

You might reach out to technical support (via the chat in Zwift dot com) and report your issue and update them with your logs. Your logs will be more helpful than what I’ve been asked to provide.

Same here. Lost training plan progress.
In the companion app the progress is still visible, but not in the Zwift app.

I think some of these are different. One is about the TP link, and the other is about the loss of Zwift training plan progress.

Hey all -

Thanks for flagging this up. We’re looking into it.

Question: Is everyone who’s not seeing their Training Peaks workouts using Windows or macOS? We have been investigating and we have not been able to reproduce on other OS platforms.

2 Likes

I’m on Windows 11 and my TP workouts are not visible/accessible

thanks

1 Like

I updated tonight before my ride. Last night I did week 1 day 2 of the FTP Builder. Tonight when I loaded the PC application on Windows, I was no longer enrolled in the training program.

I had the Companion App open on a phone while the update went, and was looking at the workout for the day. When the PC completed the update and I started the program, the Companion App ‘lost’ my training program as well.

It appears that the update erased my training program. Anyone else have a similar issue?

2 Likes

My training plan I was working on just vanished. No progress anywhere. So I re-enrolled and just checked off the ones complete and did another. Logged back in to check out these glasses in the garage and the plan is gone again…this included computer and Companion

3 Likes

Yes - see below. But it’s happenex twice now since update.

1 Like

Same issue for me (regarding losing progress and enrollment to training plan). Anyone heard anything about a fix of some kind?!

1 Like

Hi. I’ve unconnected and reconnected Training peaks to Zwift. Sets are showing on my mobile but not my mac? I’ve removed the app from the mac and reinstalled but still an issue.

HI, same issue here. After 5 weeks of ward sweat I just lost my progress on “Build me up” training once I updated to this latest version. I remembered what was my next training so I was forced to do a new signup in the training and continue from there, but totals and all previous progress is lost :frowning: . Need help!

This is also happening with custom workouts imported from Today’s Plan. No issues yesterday on my mac prior to updating and I can still see them on my iPad after updating but they are missing entirely from my mac after updating.

1 Like

Please help, i have the same problem. 6 Weeks hard training lost!
I am Windows 10 user.

When i use the Zwift app on the Iphone (Not companion) everything works fine, but the screen is too small for me.

I remember TrainginPeaks workouts not showing up the last time we changed to/from daylight saving time, and it’s happening again. I think?

I’ve tried logging off of TP and Zwift, then back on, disconnecting and reconnecting in infinite combinations, but still no luck.

Anyone else having this problem?

1 Like

yes - I’m having the same problem. have done the same things as you and I can’t get the TP workouts to show up.

I have the same issue, after the update today morning i can`t get the training-plan workouts.
I am training in calender week6 of the build up plan. Now the app would let me start the training plan from beginning.
When i start Zwift, the pop up window to select the training out of the training plan does not come.
When using Zwift with the Iphone it works, but thats not the solution i would like to have.