Training Peaks workouts went away [Nov 2022] [1.31] [SOLVED]

I emailed Zwift Support Team re: this issue, as both myself and my coached clients use the TrainingPeaks feature. Support got back to me right away!!! (5* from me!!!) to tell me they were aware and on the case.

RE: @shooj 's previous message, calendared TrainingPeaks sessions are still ‘working’ on the iPad (therefore I guess the iPhone etc. etc. too!) which is good news and a possible workaround

TP training plans disappearing but my full-length TP plan vanished from Zwift’s workouts tab.

I have unconnected and re-connected Trainingpeaks and Zwift and restarting the computer hoping to make it all work together again and it doesn’t. Tell me Zwift is working on solving this issue.

Exactly the same for me Ashley- Mac OS doesn’t work but worked in companion app except power management which is fluctuating to the point it’s unusable!

yeah, it’s been a few updates since it’s been getting harder to choose the TrainingPeaks workouts, but with the new update they are gone!

Please fix this ASAP

This is still an issue for me. No Training Peaks workouts displaying within the Custom Workouts section in Zwift.

This feature worked previously on PC Zwift client. Fingers crossed for a speedy fix.

Just as a note – it appears than TrainingPeaks WOs will sync to PCs with the 1.31 update if the PC had never had Zwift installed on it before. I used one of my family members laptops instead of mine last night and I was able to get to the TrainingPeaks WO without issues.

However, even uninstalling/reinstalling Zwift (and associated files) doesn’t seem to fix the issue if you previously had Zwift on it.

So, a partial fix if you have access to more than one PC to use (we’ll see how long my kids let me steal their laptop). -SNB

1 Like

Adding my +1 to the thread. TP workouts disappeared after the big Makuri Island update a couple of days ago. Have had to manually move the zwo from TP into the zwift folder to be able to do them.

Windows 11 64bit

1 Like

Just adding another user who can’t access TP workouts. MacOS.

Adding another to the thread - no TP workouts visible in Zwift since 10 Nov. Windows user. Have tried de-linking and re-linking Zwift to TP twice. But it made no difference.

Same issue as well. Unable to see TP workouts in Zwift.

+1 to this thread for me as well. Previously Zwift automatically imported workouts from Trainingpeaks. Now I have to manually export the workout ZWO file from Trainingpeaks into the Zwift workout folder for my userid, then start the Zwift application. I run Zwift on Windows 10.

I use a new Macbook and after the update, my week 5 progress of the FTP builder plan is gone. My Apple Watch Zwift Companion app that I use for the heart rate monitor also no longer syncs with my phone companion app or Macbook.

any news, we have a large group ride with Trainingpeaks workout tomorrow morning.

Same issue with a Mac Book. Since there is no Zwift update, I take it this still hasn’t been fixed. Sigh. I will use iPad but would be nice to hear an ETA…

UPDATE November 11
We are still working on this bug, and it did not make it into the v1.31.1 patch for PC / Mac that went live a short time ago.

Please bookmark this thread for progress reports. Thanks for your patience.


Would this work on Mac Os?
If yes, can you point me to some instructions please?

11/14 around 7am US Eastern - Windows 10. Got up to ride. the TP workout was in my list - Great - I thought.
I selected the TP workout.
When I started, all of the segments in the workout were configured as “Free ride”, and occasionally I would see a message like “RPE 2” in the middle of the screen.

So while the TP workout segments were there, and the time of the segments was correct, there was no ERG at all.

I also tried this same TP workout on my Android device and noticed the same thing. Everything as Free Ride/no ERG.

11/15 around 5:30am US Eastern - Windows 10. Seems to be fixed - had a successful workout this morning using a TP workout.