Training Peaks Custom Workouts Not Syncing [March 2022]

All of a sudden, none of my TrainingPeaks workouts are syncing with zwift. Tried all of the usual steps - disconnecting and reconnecting, etc, and still not syncing. Problem has been going on for about a week for me. Extremely frustrating.

I have the same issue loading plan onto Zwift. Workout results are going from Zwift to TrainingPeaks. any solutions? Tried connecting and disconnecting on several devices, and hasn’t worked

I signed up with a coach via TP and he loaded a bunch of workouts on my TP calendar. So far, I don’t see anything TP-related in Zwift. All I see under Custom Workouts is “Create a new workout”. Fingers crossed it syncs tomorrow because it will suck hard if it doesn’t work.

Seems like I should be able to see a placeholder in Zwift for TP. Nothing. I wonder if this is something that works for some but not others.

I also wonder how long it takes for the workouts to sync from TP to Zwift. Should it be instant? Overnight? I entered a “fake” workout in TP for today and disconnected/reconnected via the app and the website, but no luck. I’ll post an update here if it magically works tomorrow when the real workouts are scheduled to start.

I think it will only show you the workout if it is due on the same day.

1 Like

You were right. I put a test workout in TP yesterday and it’s in Zwift this morning.

So the evidence suggests Zwift only displays the workout category if there’s content in that category. While I’m happy with the way it is, my suggestion is to display the category regardless of the content so there’s a better indication it’s working.

Better yet, perhaps it could scan ahead and display upcoming workouts, or display “no workouts for the next X number of days” so a person can predict if it’s working or not.

1 Like

I have the same issue :frowning: I have tried to connect and disconnect for several times. No workouts appear on the Zwift.

1 Like

I have just had a coach set up some workouts for me from Training Peaks and I thought I had the same issue. I am using an Apple TV and nothing shows up under Custom Workouts on the top level menu on the Apple TV, but on my PC the workouts are there.

After some messing around on the Apple TV I ended up selecting another workout, then when the older style workout menu shows up, I was able to scroll back up to the top and I found that there was indeed a “Training Peaks Custom Workouts” folder there and it had the workout in it.
It’s not a great experience having to jump through hoops to find the Workout in the menu, but I suppose I can be grateful that it was there at all. I guess the issue of it not appearing in the Custom Workouts menu at the main screen is a bug in the tvOS/iOS version of Zwift.

I have android device. I have checked it on both phones and on tablet. There is only one workout option and there is no training peaks “folder” visable. I have all other workouts, including those which were prepared by myself.

1 Like

I have the same issue here. Is the any solution to fix this. The trainingspeak workout is not syncing into zwift. Of course tried to disconnect an reconnect the zwift an TP account. Any other ideas?

I actually have a unique varation of this issue. I recently removed and restored the connection to TrainingPeaks to Zwfit. I now see my planned structured workouts in Zwift but none of my zwift rides are getting over to TrainingPeaks so it looks like I’m not doing any of them. To be complete, I also have garmin and strava and I DO see the zwift rides in those apps, just not TP. I also have zwift connected to Strava in addition to TP and TP is connected to Strava so the completed workouts are NOT getting to TP directly from Zwift nor are they getting over to TP via Strava.
What to do? That is the question. Let me know if you have any ideas.

I am also having the same issue… I am on Apple TV and an Apple phone iOS 15.6.1. Neither shows the Training Peaks tab under custom workouts. I have uninstalled and reinstalled the app plus removed the link to Training Peaks and linked it back up multiple times. Still not working. Might have to try Wahoo RGT to see how well Training Peaks links to that platform.

I wish I could help. I was worried it didn’t work at first, but I learned it only shows on the Zwift menu if there’s a workout scheduled in TP for that day. And it only shows that day. Would be nice if it displayed in Zwift even if it’s blank.

Is there some pattern here with Apple TV? I’m not even sure what ATV is. Some sort of streaming box? Maybe it’s filtering it (the connection/data) out. Again, if Zwift showed a blank category, then we would have a bit more info.

I’m curious if RGT works with TrainingPeaks. Zwift is good for racing (Cat issues aside), but I’d rather to training rides in real environments.

Well after reading this complete topic, it seems that we don’t have a real solution to the issue. I’ve tried everything and I still cannot find my workouts nor the Training Peaks tab. Please Zwift, help us out here.

My TP workouts synced fine until this morning. Tried everything mentioned in this post, but nothing seems to be working. :frowning:


Same here…

No Training Peaks custom workouts displaying for me 10th Nov 22 using ios, following Zwift Update Version 1.31.0.


Same issue for me….I get them on my iPhone but not on desktop running a Mac….no issues until today with new Zwift version.

1 Like

same issue here too, disconnected the connected between tp and Zwift no joy. Even manually exported the file from tp to my Zwift folder and still nothing. all updated versions and training sessions are a mix of power based and rpe. sucks as this is my main reasoning for having Zwift. if this doesn’t get solved think ill cancel my subscription. And another rant is the supposed online chat to an agent just crashes. sort it out Zwift !!!

1 Like

same here

Same here- bloody hell Zwift sort this out.
Works on Zwift on my iPhone but the connection with my smart trainer now has the power fluctuating ridiculously so can’t do that.
Copied it to Zwift folder and still not there.
The update has screwed everything up.

I don’t care that it’s rare- SORT IT OUT NOW