Training Peaks Custom Workouts Not Syncing [March 2022]

same for me, the new update might have broken something

So I’ve spent this evening recreating as many of my TP workouts manually in the custom builder on the Zwift app.
They’re showing up in the Custom section under “Workouts” but I haven’t tried to ride one yet.
This is the best solution until Zwift fixes this problem.

(The .zwo file import to the Mac OS folder from TP directly or by email drag and drop still doesn’t work so the problem seems to be the TP server interface to source folder READ/LOCATED by the Zwift app rather than using the Zwift app builder function which places the workout properly)

I still have a hunch that this is an Apple issue. I run Zwift on my PC/laptop and import without issue. If I had an issue using an Apple platform, I’d try bypassing it, but maybe folks are trying that without success.

Same Problem here; Please fix it!
Thanks.

Hi Worked for me last week. Just wanted to start my wokrout right now. Not finding my workout or even the TP dropdown…

Any issues currently?

Thanks
Paul

I have been experiencing this same issue since the beginning of January. Before Christmas my workouts were syncing, but it’s now stopped doing that.

I’ve tried disconnecting and reconnecting Zwift and Training Peaks in both directions - and each are paid subscriptions - but nothing works.

Any other suggestions?

I was having the same issue, but eventually figured out how to resolve things syncing from TP into Zwift. My coach was building workouts that were categorized as “% Threshold HR”. You’ll see this in the “units” drop-down within TrainingPeaks.

In order for the workouts to appear I needed to change the “units” to reflect “% of Functional Threshold Power” or FTP.

Once I saved and updated my workout in TP it now appears in Zwift on both my iOS and AppleTV devices

I don’t see the unit dropdown you’re describing. Can you be more specific on how to change this?