Tacx Neo Smart 2 cadence issues after Zwift update


(Vincent W.) #21

Remember everyone to please send in a support conversation so we can collect your logs and specific setup information!

Support Conversation link: https://support.zwift.com/contact/contact-us-HJH8N4RNQ
How to find log files: https://support.zwift.com/en_us/how-do-i-find-my-log-files-(cycling)-SyTW0JZSX


(Martin Smits [Neo]) #22

The problem is not caused by Zwift but by the Neo 2. Tacx is working on an upgrade. When there is an update available this will be posted in this forum.


(James Roe) #23

I don’t think it is Tacx as the cadence works fine on every other third party app, only zwift has the problem.


(Tom42170) #24

Hello

Same problem with my Tacx Neo 2, the cadence is normal in the Tacx Utility App but crazy in Zwift (When I ride at 90rpm, the value displayed in Zwift changes each second: 0, about 90, and about 170rpm)

For workouts without rpm requirement, the ERG mode is almost ok, despite of the cadence issue.

But impossible to achieve workouts with ERG mode and specific rpm to keep.


(Valentin Zayash) #25

I’ve got the same information from local dealer.
Maybe you have some reply from Tacx support?


(Lutz Jeremie) #26

J ai le même problème de cadence avec ZWIFT, elle fluctue en permanence de 0 30 130. Avant la mise à jour pas de problème de cadence.


(Sumit Karia) #27

I have the same problem with my neo 2. Cadence is all over the place. Normal on the tacx utility app.

So assume its a Zwift or bluetooth issue?


(Tom42170) #28

Hello,

I got an answer from Tacx support, which solved the problem:

We believe that we found a solution for this by updating the firmware.
This firmware is not available in the Utility app but will be released soon.
You can also upgrade the firmware via the file in the link below:

Can you please try attached download firmware link on your smart trainer with the Tacx Utility app.
Forward his email to an mail address that you can access on your smart phone.
Now open the email on your smartphone and click on the link below:
https://drive.google.com/open?id=1KHYsvoaYeLootSQmjN0dxBl00PWGNN_9
Be sure to click on the download button (marked by a red circle in the image below).

Choose to open this file with the Tacx Utility app and connect your trainer (wait for the circle to become green).
When your trainer is connected choose "Update" to begin the firmware installation.
Wait for the firmware installation to complete and follow the instructions on screen when necessary.
Once the firmware is installed, you can use your trainer again.
Sorry for the inconvenience.

==> The version 0.0.18 for Tacx Neo 2 in the Tacx Utiliy App solves the problem of cadence in Zwift ! :slight_smile:

Thomas


(Valentin Zayash) #29

After updating trainer to 0.0.18 there are no more blinking cadence but values are still cheating,
stuck on some value, for example 24 RPM for 100-200-300-400W on the same gear


(JAMES McG Ashmei Musette RT) #30

Neo 1 owner , my cadence is reading stupid high or normal after latest update. MacBook pro latest iOS.


(Vincent W.) #31

Hey James can you make a separate thread for Neo 1 or send in a support conversation?


(Peter Mergaerts) #32

Fixes the issue for me. BLE is as stable as Ant+ again!. Thx for sharing!


(Andreas Gad) #33

Fixed it for me as well. Thanks a lot
:+1:t3:


(Lutz Jeremie) #34

It s OK for me.:ride_on: Thanks a lot.


(Frank Taelman) #35

I had also cadence issues and this firmware update did improve. But still inaccurate cadence values during my training just finished.

Don’t know what else can be done


(Gildo Silva) #36

Hello.
I made this update to neo2 and the problem was solved

tks


(Jakob Dral) #37

Hi,

did the update and have also issues again. It stucks at different values for a while like the others. I hope I can solve it with ANT dongle, becauase actually not possible to make a training with this cadence issue.


(Jakob Dral) #38

Just received my ANT stick, other issue. Cadence stuck at highest value and needs about 10 seconds to refresh. Powervalues are correct and smooth. Doesnt’t work .15 firmware and .18 firmware same issue. Now I have to buy a separate crank sensor, not possible to drive trainings with this issue.


(Gildo Silva) #39

try to use the BLE… and see what happen


(Jakob Dral) #40

I tried different settings also with .15 and .18 firmware. No way to display the cadence correctly. Had before the Tacx flux and there were absolutely no issues.