Tacx Neo Smart 2 cadence fluctuating widly or showing no signal

Something isn’t right. Where did you download that file from? There have been many releases since Oct 2020. Actually the latest release was yesterday:

  • Mac : 1.21.0 (100317) (January 12 2022)

I would start by getting the latest version of Zwift installed. Then, try again and let us know.

1 Like

Zwift on my MacBook Pro will auto-update when I start it up, so yes, it’s quite odd to see a macOS user with the October 28, 2000 version of Zwift in use.

That is weird isn’t it. I had the latest Zwift on my Macbook last summer when I got the first Neo 2T. When I talked to Tacx yesterday they asked me to delete/reinstall Zwift - not sure where I got it from (the Apple store?) but just downloaded it from the Zwift website again and I get the same thing.

PS Just opened the Zwift app I downloaded from the Zwift website and it shows Version 1.21 on the opened window.

When you say turn off your phone - do you mean the phone’s BT (which I have tried multiple times with my 820 off also) or to power off? Should I remove the batteries from my Vector pedals too then?

You have the latest Zwift on your MacBook now, the date of the ZwiftOSX.dmg file is just the installer for Zwift. When you double-click ZwiftOSX.dmg, that launches an installer app, and that app downloads version 1.21 of Zwift to be installed from the Internet.

Your phone has the Tacx App, which you do NOT want to be running, because the Tacx App will connect to your Tacx Neo 2T Trainer, which means that Zwift will not see the trainer for pairing. If your phone is turned OFF, then you won’t risk having the Tacx App conflicting with Zwift. Your Vector Pedals are just fine, as is, but do they show up in the Zwift pairing screen as a Power Source or RPM source?

Tried to pair with my phone shut off, No luck, Contacted Garmin again - no help - they think it’s my Macbook that’s the problem, but I have paired 3 devices in the past 24h and they paired seamlessly. Have put in a request to “Zwift Ambassadors”. I have been using Duckduckgo for my search engine through Chrome so changed it back to Google, in case that is part of the problem (shouldn’t be - since the Zwift app is on my computer) As soon as zi’d done that I opened the Zwift App and try to pair - now I keep getting the following message - every 0.5sec! until I close the app.

If you have any other bluetooth devices connected to your MacBook, disconnect them and turn them off. It could be that Zwift isn’t playing nice. After you get everything running, then reconnect said devices (e.g., wireless earphones, etc…)

2 Likes

There was the same error message in Zwift about Bluetooth devices from back in 2016 and 2017.

Do you have a Bluetooth watch or fitness tracker nearby when running Zwift? I’ve never seen something like this when running Zwift on my MacBook Pro, iPad, iPad Pro or Apple TV. Sorry to see the continued tech drama with your setup. Oh, do you have any Bluetooth dongle plugged into your MacBook Air? It doesn’t require any dongle, because Bluetooth is natively supported.

1 Like

I’ll add my 2 cents for what it’s worth:
An hour of my time is worth more than the cost of the dreaded Apple TV from the evil empire, so I have one now. And it’s working 99% of the time. I have over 30 years in the IT industry & teaching tech. I feel my knowledge is pretty good when it comes to sorting out technical issues.

I have ran Zwift unsuccessfully on 2 – Windows desktops, 5 – laptops, including a MacBook. I say unsuccessfully because I was able to sort out the issue(s), and it worked for a while. Then it would start crashing. I noticed this more after an upgrade of either windows or Zwift. I felt that even on the MacBook there were too many other “things” (.dll’s, video driver versions, BTLE revisions and driver conflicts etc.) to waste my life on.

After speaking with a large number of my friends that use Zwift, and reading the forums, talking to people while Zwifting, I finally – after more than 2 years of pain & time – bought the latest and greatest ATV. I’ve had no issues for about 6 months.

I do agree with the troubleshooting steps above. Eliminate everything possible so you can isolate the issue. It’s all been said above.

My current setup is a little complex. Sorry there is no diagram. (Dan)

I do some testing of devices so I know for a fact that the Tacx Neo 2T, Neo 2, and Neo all connect to BTLE and ANT+ simultaneously. The biggest flaw in the Neo series is the cadence and it has been for each of the devices. That story is above. (note that some people say they don’t have this issue).

I have an ATV connected to the Neo2T and a Garmin HRM using BTLE. At the same time, the Neo 2T is broadcasting ANT+ to 2 – Garmin Edge 830’s and a Fenix F6. The Garmin HRM is connected to the ATV, 2, Edge 830’s and the F6. I also have Gamin Vector 3 and Rally pedals connected to one or more of the heads depending on the testing. So, concurrent connections is not the issue.

MacBook likely shares the same connection limit that the ATV does. (but I don’t know if that’s true). Max 2 Bluetooth devices. After that, companion comes to the rescue.

From the diagnostic logging that is turned on for data collection on the Edge devices, it is visible that the Neo does drop connection, but not long enough for the Zwift gamming app to notice.

It’s important that the Neo is on the latest firmware which is 0.0.38 as of last week when I checked. It resolves a number of issues depending on the firmware that your Neo is on. But this does not fix the cadence issue. You can update the firmware via the Tacx App, if you haven’t already.

This probably doesn’t help, but, that’s my 2 cents.

1 Like

HI @Jimmy_Moceri_Handbik , sorry to hijack this thread but I found a photo of your setup on Google images. I’ve just tried to attach a force RX to a Tacx Neo 2 like how you’ve got pictured but its a no go. My dropouts and rear mech are hitting the cassette and the fork is just touching on the otherside, did you have to do anything to get this setup to work?

My Apple TV setup running Zwift is rock solid, no issues. Companion App runs on iPad Pro, and reads all sensors, including a Quarq power meter.