Steering mode stopped working [v1.12.0] [April 2021] [SOLVED]

The zero in version 1.X.0 indicates a major version release, usually with some new features in there.
The dot-one in v. 1.X.1 indicates a minor release. In general - minor releases patch known issues, and that is the case for 1.12.1

This simplified version numbering system has been used internally forever - we are now using that system externally as well.

AppleTV currently running v 1.0.67624 again, when is the patch being pushed out to iOS???

EDIT: v 1.12.1 is available on all OS platforms. Please update your game app to fix this steering issue.

We’ll update our Latest Version thread as we release on each platform

I have the same problem wahoo kickr bike, Apple TV after update no steering but icon say it’s on :confused:

Same for me steering on my kicker bike stopped working, after update, using iOS

Me too - Kickr Bike, Mac OS

Shows steering icon, buttons do nothing - free ride in multiple worlds / courses.

Bike is new - this was my first experience - great thanks.

There was an update pushed out to Mac and PC last night to fix it, give it another try.

New release worked - solved both problems. Thank you.

Confirmed working with recent update, thank you!

Sam here - confirmed working on Apple TV via companion App (iOS). Thank you for fixing this for US, much appreciated. Best wishes and stay safe.

since updating zwift yesterday I have lost steering again this is ridiculous

I have same issue. Already update to latest zwift version and kickr bike firmware. Both iOS and Windows 10 stopped working.

Steering with my kickr bike doesn´t work anymore as well.

Hi, unfortunately, once again, my Kickr Bike steering stopped working. It did work after v1.12.1 but at some point after, stopped working again (I forget when). After pairing, I can see steering icon on etc, but the avatar does not respond at all to the steering buttons when free riding a route.

This is an old and superseded thread, which should be locked really… There’s a new patch out which should resolve your issue (again :wink: ).

Same for me and I am on the latest update - Zwift support have confirmed it is being worked (again). So not sure this should be locked or sadly is ‘old’ as there are plenty of us getting this on the latest code.

That’s great - Zwift support don’t seem to know about it yet though as I had an email from them overnight saying its a known issue, but no fix as yet. Will give it a whirl.

Yep - today’s update seems to have sorted it.

Thanks @Dave_ZPCMR - will give that a go this evening!