Steering mode stopped working [v1.12.0] [April 2021] [SOLVED]

Since last update same problem on Wahoo Kickr Bike

Same Problem here too, hope its fixed soon.

Another one on Apple TV over here

Hi, 🙋 having same problem. I have Wahoo Kickr bike and steering no longer enabled since latest update of Zwift app on my Windows 10 PC. I have not tried on my iPad as pairing my heart rate monitor is more reliable with PC. Didn’t think I’d miss steering that much but I do because it’s just more interaction with game when free riding.

Yep same problem here as-well, I’m also on Kickr Bike with Apple TV, thought it was the trainer so tried a few things and no luck so thought I’d google problem which led me to the forum, bit of a relief to find others having issues I thought the shifters we’re playing up .

Thanks. Same issue. Kicker with iPhone app casting to appleTV. Steering stopped working.

Same, Steering says connected but not working. Using Apple TV & worked prior to update.

Also using Campagnolo set up means that the gear controls are also the steering controls. Very annoying ( prior to above steering not working) when you change gear the bike moves. For those using Campag set up can you not set up to use some of the spare ‘other’ buttons for the steering. Thx

I’ve been having the same issue as well. Thought it was my Apple TV and changed over to my Mac computer but was still having the same issue. As the issue continued, thought there was something wrong with the Actual Kickr bike, but no. Glad to see I’m not crazy and others are experiencing the same issue.

1 Like

I am using a Kickr Bike with an AppleTV 4k - and the steering says connected but does not work.

I have same issue with steering not working.
I tried in a ‘steering race’ and in a free ride.
I have KickR bike and PC.

Hi, this is my first post so I hope I am in the right place. I have a wahoo Kickr bike on which the steering function randomly ceased working about a week ago. Nothing I can think of has restored it. Is this a known issue ? This is on iOS via iPad Pro

In case you didn’t see my post highlighted upstream - this will be fixed in this week’s game patch 1.12.1 :grin:

Are we there yet? Almost. Zoon™.

4 Likes

Hi Shuji Will the fix cover both the Steering and the Ride on issue?

Similar issue here: new KICKR Bike with latest firmware, Apple laptop and iPhone. Steering icon illuminates and the Future Works notice about steering comes on, but the buttons do nothing. Awaiting developments and thanks for looking into this.

Same . And on April 22nd my companion app no longer sends data to show the workout on Fitness app (iOS)

When will the patch be pushed to AppleTV OS?

Hi I use Kickr Bike and Android Zwift App. Steering doesn’t work either. Regards Stephan

I’m having same steering

issues since update .I’m on kickr bike also .

I’m having the same issue.

Is this going to be an update with features or just bug fixes?