Steering connected with Kickr Bike but doesn't work

Hi. I’m new to the forum and appreciate any help you can offer. I have a 1st Gen Wahoo Kickr bike with up to date firmware. When Kickr steering with Zwift originally launched it only ever worked intermittently. Some months ago after a Zwift update I got a new connection screen and I was excited to see that steering was connected. I also got the steering icon by my name in the game and steering worked. Well that lasted a few rides and now it never works. It still connects via Bluetooth every time and I see the icon in the game but the steer buttons do nothing and sometimes I’m stuck in either the right or left edge of the lane. I have contacted Wahoo support but they’re not offering any solutions.
TIA for any ideas.

Hi @Ralph_Poplawsky welcome to Zwift forums.

By any chance are you pairing to the KICKR Bike using an ANT+ dongle? Steering is not supported over ANT, only Bluetooth. See this support article for details.

Trainers will broadcast ANT+ signals quicker than Bluetooth. If you’d like your PC / Mac to forget you were ever paired over ANT - you can delete a file in your Documents\Zwift folder called knowndevices.xml

Then - fire up Zwift. When you pair - pair the Power signal first.
Then click Controllable. It will take ~10 - 15 seconds before the Bluetooth signal is picked up, but wait for it to appear.
Then click Cadence, heart rate, steering signals, all in Bluetooth.
Once you exit Zwift, a new knowndevices.xml file will exist and remember you prefer to connect using Bluetooth.

Does that solve your issue?

Shuji, thank you for your excellent and detailed reply. The short answer is yes my problem is solved. I really appreciate your help!