FutureWorks Steering Phase 3 - Kickr Bike

Description for an event tomorrow says steering is enabled for Kickr Bike but no further information on how it’s enabled/works. Does anyone know any more?

Phase 3 of FutureWorks Steering is here! We’ve now also enabled the Wahoo Kickr Bike in addition to the Elite Sterzo Smart Steering Plate, extending the latest in racing to more devices. Choose your line and position yourself to maximize the draft. You and your avatar are about to bond like never before. Part of the FutureWorks platform is to collect feedback from our community: Tell us what you think by leaving your feedback in our forums after the race!

See this post: Game Update - January 21st, 2021


We have a new Support Hub article on using steering with the Kickr Bike

Have taken the update and attempted to connect to steering with the Kickr Bike but no success. I have powered of the bike, reconnected the handlebar and attempted riding, pushing the buttons, pairing after I started riding and restarting the game but it doesn’t connect. My Sterzo connects without issue for my prior setup.

Just tried using the steering on my Kickr Bike to no avail. That Future Works icon never pops up and nothing happens when I push the side buttons. I’ve reinstalled Zwift and still nothing.

There were three sprints on my meet up ride today but only the first one displayed results. Is this a new bug?

Took the update on IOS and boom it found it right away. Steering worked like a charm. So the issue is with the PC update right now.

Steve, any luck with the IOS app? Steering issue seems to be specific to the PC app.

You need to be paired through Bluetooth. Steering doesn’t work through ANT+. In the linked article, there are instructions to use the Zwift Companion app to use steering if your computer doesn’t have BLE (mine doesn’t). Good luck, I think we’re both gonna need it…

Here is what I have debugged. If I use a PC that did not have a steering device previously connected it works great. What I can’t figure out, after deleting Zwift, the user files, the registry key and reinstalling the app…it still remembers my name and that I had a Sterzo. Need to find where it hides that in the registry or settings that don’t get deleted when you uninstall Zwift.

Looks like it is bluetooth only. That is disappointing.

Team Zwift - is this truly only bluetooth for the time being? Will ANT be supported for steering.

Apple TV app updated this morning and steering connected without me doing anything

Should we now be able to do repack ridge w/ Kickr bike steering? The option to turn onto the trail doesn’t pop up for me now on Apple TV

Never mind - just saw it isn’t supported for repack ridge

Got a Bluetooth dongle to replace the ANT+ one I’ve been using on my Zwift computer; it’s a desktop workstation unit and it doesn’t have Bluetooth. After fooling around getting it paired to the Wahoo Bike, it works great. Gonna take some doing to not be hitting the buttons when I’m shifting but I think I’ll manage. It certainly makes other riders do some funny maneuvers to avoid riding through my avatar. I didn’t do a “serious” ride with it so we’ll have to see how it goes in a pack when the time comes. Wish I could’ve run this in the DIRT Sprintapalooza yesterday…

Hello, with the latest update on my iPad Pro (2017) and on my Iphone 12 Pro, it won’t let me connect via Bluetooth to my Wahoo kickr bike. The zwift app keeps looking for the trainer.

With another Ipad Pro (2020) and with my laptop, I was able to connect, but I think there is a connection bug with the IOS devices.

I managed to get steering my Kickr bike using the app on Win10; I then downloaded the Zwift android app and steering worked on that; Since the screen was to small, I went back to the PC version. The steering icon is there but it now does not connect. Tried uninstalling and re-installing etc, disconnecting and reconnecting Bluetooth, ANT+ etc but no luck. Can you advise?

Ahhh, this was driving me mad last night - no pop up navigation, so I disconnected and the pop up “popped up” - I went onto Repack, re-connected but then the steering didn’t work… what’s the point of them having it partly work? Surely anyone with a Kickr bike was immediately going to go to Repack to have a go!!

The release notes (link in 2nd message above) do say that it doesn’t work yet in repack ridge

Hi. I have Apple TV and I don’t see the Steering option. I have Kickr Bike.