Solution ANT+ connection

I’m trying to connect my TACX Neo 2T through an TACX ANT+ Antenna through Zwift on my Laptop. Whatever I try I can’t select it and get it fixed. It seems that I’m not the only one.
It only shows an ANT+ logo with an error mark in it next to the Bluetooth beacon in the Zwift Paired devices Menu. And when it doesn’t show an error mark in the ANT+ logo in the paired devices menu I can’t select it after searching for it. I tried the following:

  1. Two different Windows Laptops (1 Windows 10 & 1 Windows 11).
  2. Stopped the TACX Trainer app after first having Enabled the ANT+ Sensor profiles under the device default menu before trying to connect it again.
  3. As stated in another topic thread about it reinstalled the Zwift app on both devices and rebooted the system.
  4. Used a direct USB port on the Laptops to connect the TACX ANT+ device.
  5. Placed the TACX ANT+ device as close as possible to the trainer.

I don’t understand why such a top range TACX product and top range app like Zwift with all those millions of users around the world don’t seem to be able to get this easily in “a plug and play” mode.
Is there any solid solution or should I just drop the ANT+ connection and buy a cabled Bluetooth dongle instead??

Have you tried deleting the ANT+ driver and then reinstalling it again using Windows Update?

My Windows 11 didn’t have Any+ drivers installed by default. Fine since I added them manually.

It does sound like a driver problem. Did you see this post?

1 Like