ANT+ dongle not working on Windows? Solution here

Thought this was worth its own thread, since I’m seeing more and more people have this problem recently. Previously all you had to do to install an ANT+ dongle and use it with Zwift was to plug it into a USB port. However there’s some issue at present which means this no longer works. Hopefully it’ll be fixed soon but in the meantime if you’ve had a Windows notification come up saying the ANT+ dongle is ready to go, but in Zwift you have a warning triangle on the pairing screen instead of the expected pulsing rings, here’s how to resolve it.

Note that this process assumes Windows can actually see your ANT+ stick (i.e. it shows up in Device Manager), and that it’s not just faulty, or the USB port in use is broken etc.

Method one (best):

  1. Open Windows Update and hit check for updates even if it already says you’re up to date - you need to force a new check.
  2. Click on ‘View optional updates’. In Windows 11 this is found in the Advanced options menu.
  3. Expand the list of driver updates, locate the ANT+ driver (it shows up as Dynastream Innovations), select it and press ‘Download and install’ to complete the process.

This can be done with Zwift still open, the rings literally start pulsing immediately. If for any reason you can’t find the optional update, here’s how to do it manually:

Method two (manual):

  1. Download this Zip file and extract it somewhere onto your Zwift PC: Driver_ant_usb2.zip - Google Drive
  2. Hit Start, type Device Manager and then press Enter.
  3. Locate your ANT+ stick in the list; it should be standing out to signify it isn’t working properly.
  4. Right-click on the ANT+ stick and select Update Driver, then Browse my computer for drivers.
  5. Browse to the folder you extracted in step 1, click OK, then Next.
  6. Once the driver is installed, you can now delete the extracted folder and Zip file.

I feel we should have a files section :wink:

EDIT: and thanks!

1 Like

Meh, nobody reads those. :grin:

1 Like

Ran into this installing on a new computer yesterday. For some reason Windows 10 on the new PC refuses to find and install libusb-win32. Thanks for the files!

1 Like

Awsome. Solved!!!

1 Like

Lifesaver, thank you!!
I dutifully upgraded my Win 8.1 to Win 10 for the Jan 2021 Zwift upgrade (a whole thread in itself) and got ready for my event this morning and…Ant+ not working! Ticking down to the start time, all geared up, screaming at the walls and trying to troubleshoot this problem I’d about had it with Zwift, again…(those upgrades!!!).
Stepped away, calmed myself down and found your post, Dave.
Problem solved.
Huge thanks.

2 Likes

Thanks. Worked perfectly.

1 Like

Just out of curiosity, I checked the properties of my ANT+ driver, and it was from 2012. Is that really a current one or is your newer, Dave?

And indeed if the driver to use is from 2012, I wouldn’t be the least bit surprised if Windows doesn’t think it is quite up to date in terms of code signing and what have you, even if the driver itself might work fine.

Even the driver Windows itself installs (using the optional updates as method one above) is from 2012, so age isn’t the problem.

Edit: just checked, all three drivers are exactly the same. Same date, same underlying files. For some reason Windows doesn’t trust the one provided by Zwift any more, even though it’s the same. Presumably a security/permissions change somewhere.

1 Like

Thanks for your support. Method one solved missing driver after update to Windows 11.

1 Like

I have been experiencing 1 to 2 ant+ dropouts per ride that is over 1h30m in duration. The first one usually happens near the 1h30m mark and the other, if it happens, comes later past the 2hr mark.

They are long enough to cause me to get shot out the back when riding in a pack or lose credit for an interval during an erg workout. Even though the dropouts only last a few seconds at most. Even though the dropout is on the order of a few seconds, the time it takes to establish erg mode lengthens that time to about 10 seconds. When being dropped from a pack due to a momentary dropout, there is no hope of regaining that pack. They are gone.

I have been riding on zwift for years and have never experienced this. Nothing has changed on my setup: PC Win11 with ZCA iOS all running most current versions.

I tried moving my ant+ usb stick from a USB port on the computer, which is about 2 feet from the my KICKR BIKE, to a six foot cable bringing the dongle underneath the flywheel. No joy. Still experiencing 1 to 2 dropouts per ride of over 90 minutes.

That’s a different issue to the one referenced in this thread, but sounds like a fairly typical instance of signal interference. You might not believe you have changed anything (well, apart from your entire operating system :wink: ), but that doesn’t account for all the other potential sources of wireless interference in your environment.

Thanks so much! I tried a bunch of things based on google searches and none worked. This was exactly the correct fix.

1 Like

Thanks very much, Option one sorted the problem for me. Quick question…How do I get back all the hair I’ve pulled out over this? :wink: