Smart Trainer Bluetooth Connection Dropping

I have a Tacx Flux S, and have experienced issues with bluetooth connections dropping intermittently. Typically, its after a period of “not pedalling” – IE coasting down a descent, that I get a – for power output and go into pairing screen, and see “Not connected” for controllable trainer, cadence, and power connections.

Most of the time, I have to resolve the issue by unplugging and re-pairing my trainer on the screen. It doesn’t seem to be universal, as there are some longer rides where I’ll get off to refill bottles or use the bathroom, and have no issues. Has anyone experienced something like this and have any thoughts on solutions? Should I be using ant+ instead?

FWIW, Using windows 10 on a Surfacebook with the latest zwift release.

Ant+ typically performs better. There are lots of possible issues with Bluetooth signals, they seem to get more bugs and there seems to be more interference with them from other electromagnetic radiation sources. Could also be the fault of the trainer or a bug in zwift or windows.

I am really struggling to fathom why wouldn’t trainers have a USB connection… surely, you are not at all far from your compute device (though this has nothing to do with Zwift…)

No ANT+/BT/wireless interference issues what so ever…

1 Like

Because that’d require more hardware, a cable, somewhere to plug it into (not going to happen on an ATV or iDevice any time soon), and supporting drivers to be written and maintained.

5GHz WiFi should be standard. Fast. Secure. Reliable. It’s what all other connected tech uses… including the Companion App when pairing BLE devices via that.

Kinetic have shipped the R1 with a USB port. With no cable. And nothing supporting it.

2 Likes

Hi, I just got a new Flux S Smart T2900 on Monday. Since then I’ve done two races on Zwift using it, and in both races I’ve had the Bluetooth connection drop out with a few KM to go. Very frustrating, and I was close to throwing my bike out the window.

The firmware version is 3.3.40/1.1.6 out of the box.

I’m running Zwift on Windows, and the Zwift Companion app on my phone (all latest versions). Prior to this, I was using a Satori Smart and didn’t experience this issue.

When the signal drops out, the watts readout reads – as does cadence. Looking in the Zwift pairing screen, it still shows Tacx Flux as Connected, but NO SIGNAL. I have to unpair and pair again a few times before the signal comes back, and that takes about 2 minutes to reestablish.

I’m not running any other bluetooth devices in the home, and both my laptop and my phone are connected to my WiFi via the 5GHz spectrum.

Can someone please assist?

Thanks!

This is the exact issue I’ve had-- usually, the issue happens if I stop pedalling (IE to coast down a hill) and then try to start again. There doesn’t seem to be a pattern, as I’ll get off the bike sometimes for bottle/bathroom breaks and hop back on and have no issues. I have a feeling it might be due to interference with other devices (headphones, roommate’s smart trainers, phone/laptop). I reverted to FE-C ant+ and seemed to resolve the issue.

Put your log file into zwiftalizer.com and see if you are getting signal interference, most likely it is something in your environment causing it.

Yup, this happened on Monday while I was going downhill in aero tuck.

This is the zwiftalizer output from yesterday’s session. I ragequit at 5.45 LOL

I agree, my ELITE Realaxiom had a USB cable, it is plug and play to Zwift.

Now I have a Saris H3 with a usb cable running from the pc and a USB ANT+ dongle on top of the trainer. So the only difference in cables is one was plugged into the trainer and the other on top of the trainer.

I must say ANT+ is solid for me.

I’m the only one at home, I don’t have a TV or microwave, and all devices are connected on 5GHz so not sure what else may be causing signal interference. The phone was on a chair beside the Flux S so about 30cm separation distance. Hope the zwiftalizer outputs can shed some light.

Could the network connection attempts be causing the bluetooth to lose signal?

Good spot. Would this be Zwift attempting a network connection, or is it indicating a drop in the network between my laptop and the WiFi? Hmmm…

Apologies for the hijack but just wanted to know if you experienced the loss of power with Ant+ as well and this is the reason your moved the ANT+ dongle to the trainer? assuming you are running a long extension cable?
I too have the H3 with a USB ANT+ dongle but directly to the laptop, no extension cable, probably less than a meter away from the trainer but intermittently lose connection which is frustrating during races. In addition to the trainer I have my HRM which is also connected via ANT+
Is it possible my Garmin EDGE 520 plus is causing interference as well or is this just a common problem with H3’s?
Is it possible to run ANT+ for the trainer & Bluetooth for my HRM?

I never even tried without a extension cable. My pc is in front of my bike and pc’s has to many things that can interfere with the signal. My ant+ dongle is on the left side of my rear dropout.

Yes you can use Bluetooth and ant+.

I would suggest turning everything off that you don’t need like the edge

1 Like

I’ve had this exact issue with my Tacx Flux S, paired to my Mac via Ant+ dongle. It cut out whilst doing a supertuck in a race, making me lose position (I too could have throw the thing out of the window). I contacted zwift and they suggested it may be another device interfering with the signal, so I switched off my Sonos speakers and this has fixed it. Very frustrating though as it means I now have to listen to music via headphones. I’m in the process of looking to buy wireless headphones but I’m nervous that I’ll invest and the same will happen. Any techy folk know whether or not this is likely…??

Hello Guys. I was having the race of my life yesterday when all of a sudden power output was totally lost and got dropped in the race. Perhaps one of the most frustrating things ever that led me to (nearly) throw my bike out of the window from the second floor. I thought it was my fault for not having fully charged AA batteries in my Satori Smart. So I headed to the supermarket, got some new batteries, replaced them in the trainer and…the problem still persists…totally frustrating and annoying. Is this problem more related to Zwift than the trainer itself? I´ve been using MAC Os for more than 3 months with no problems whatsoever so this bug was totally unexpected.

Hi @Ruben_Machuca_Kuhnel

I don’t recall a Zwift update in the last few days. Did you test the trainer with another app?

Jul 8th was the last update… and it is very possible, new bugs were introduced (it is all S/W, after all…)

In fact, I see more BLE issues mentioned lately… not a lot, but they do seem to be on the rise.