Signed up for an event - never prompted me to join? SOLVED

Hello everyone,

new to Zwift so still learning the ropes. Extensive IT knowledge and experience so know my way around things, usually.

Today i decided i want to ride with other people, so i joined a 6:30pm event via the Zwift App on my Android phone (the Upcoming Events area in the top right) then showed the Orange “Going” beside it.

Doing some quick reading, someone notd you need to be “in-game” in order to get prompted to join the event you choose…okay, in game i went, 15 mins before the event started, so, 6:30 comes and goes… No prompt to join an event…nothing?

So, i see the event is there, on my Android phone, says i am going… so i un-click it, at this point it is in the status of “Started. Join Now!” So I click on it again, says “going!”

But does nothing, so never got prompted or pulled into the event.

Am i doing something wrong? Would love to get into some events and group rides, riding around alone while nice sometimes, gets kind of depressing!

Were you in Watopia or one of the other worlds riding before the event, or sitting on the route selection screen?

1 Like

Hello Mike,

I was in London, doing the flat ride at the time

Hello,

I am hoping tomorrow to maybe try and event or 2, but want to make sure I am doing it right to join the event? Do I just join one and make sure I am in a ride for it to prompt me to go into the event?

Normally I choose an event in the companion app, then get ready to go to my paincave within half hour of the event start. When I log in, I choose something, don’t really matter what, to to a warmup. At this point I see the blue “Join Event” button already in the down left corner. I do my warmup and at 3:59 min a “Join now” prompt appears in the middle of the screen, counting down 30 sec. So usually I do nothing and 3:30 before the events starts I’m in the start pen.

I once had this, when there was no button and no prompt. That was a last minute calling. But I was able to quit zwift, restart and late-join the event.

It’s really not that difficult, you just have to get used to it.

2 Likes

Thank you @Bench , I just wanted to make sure I was doing it right since it didnt let me in before.

For the events that have started already, and you can late join, should i also get prompted for those to join once i start another ride?

Yes, you should get the same “join now” button, afaik.

1 Like

Once again, did not pull me into the even or prompt me to join.

Choose an event that started at 7:20pm via the companion app. at 7pm. Joined a normal ride in New York, rode for almost 14 mins. When i signed up for the event it asked it to remind me at 15mins - no reminder in Zwift or on companion app.

!

I then exited my ride (another annoyance when i save my ride it completely closes Zwift to the windows desktop or if i decided not to save a ride, close the app entirely…) When i came back in on the Windows app it shows the ride i was to be in, said “Going” and if i hovered over Join Now it just changes to a LEAVE button.

Video of just before the event was to start: (Hopefully YouTube upscales the quality quick…

The first time it did not pull me in, i was using my Android phone, this time i was using my Windows 10 PC and Zwift app with the companion app on a tablet.

Seems it is not me?

Also don’t sign up for a event whole on the start up screen. Do it before opening Zwift or while already riding.

If you do sign up before opening Zwift you should see going on the main page.

Also: if you don’t see the join event 10 minuets before the start, open the companion app and unjoin and rejoin the “join now” button should appear shortly

1 Like

I really appreciate your help so far Gerrie. I will say joining an event should not be this complex, this reminds me of a system that was “designed by developers”. Something so simple in nature, should just be as easy as click and go with in 1 app and be done with it.

Steps:

  1. Closed zwift on computer

  2. Started Companion app on tablet and joined an 8:05pm event - noted as Going - did show me a reminder in my Tablet notifications at 15mins (i was expecting one in the App directly)


  3. Started Zwift app on computer - showed me as going for the other event it did not pull me into and the new one 3R InnsBruckRing… (the first event left to make sure nothing interfered)

  4. Joined the Volcano ride in Watopia and started riding…Video below, 1 min left and as we can see, does nothing, does not pull me in, switches to say the event has started…but i am still in Volcano…

Something certainly does not seem right with my account or something…I just want to ride with some people :’ (

I presume I should see this like the picture in step 3, Like in the Royal Classic it states Join Now! (but that does nothing and is not an active button, just changes to Leave)

Just re-reading things

I do not get the on screen image they show:

1 Like

Lets throw something interesting into this mix…

I installed Zwift on my main Desktop computer, and guess what…as soon as i went to Ride just to see…it then showed me the prompt to “Join Event” for the ones that did not show on my other PC… So one computer hows me the Join Event…but the other one does not…

I even entered and event that had already started, went on a ride and BAM! prompted me to Join the Event…

So Android phone and other Windows 10 1909 PC do not show it, but other Windows 10 1909 PC does show it.

1 Like

Solution found. Support replied back to me saying it was likely my internet connection or hardware and sent me to this link:
https://support.zwift.com/en_us/issues-with-internet-connection-HyKyrf3pH

Inet connection is rock solid and everything else works…, and I have my pfsense set to monitor and notify if it ever goes down. But that lead me to search on what ports does Zwift need to run.

Instead of sticking to 80/443, they have other ports required for Events and other data for the client. This is why on my main desktop it worked. I have it wide open to outbound traffic.

Came across this link, which has been updated as of Feb 2020 (more recent than the above link) and provides some insight into ports, however missing 2 of them:
https://support.zwift.com/en_us/check-your-internet-connection-error-SJtFv63fr

My Wifi Network I have locked down tight to limit what ports have outbound access.

Searching, found another thread here asking for Zwift to clearly define what ports are required for the App to work:

So, from monitoring my PFSense firewall for my Zwift box the following is required (most covered in the Zwift guide but 2 are not.

Ports:

  • 80 TCP
  • 443 TCP
  • 3022 UDP
  • 3023 TCP —> tries to connect on this port first, once you allow it, connections to port 3022 and 21587 are requested by Zwift.exe
  • 21587 TCP

There are various IPs they connect to being Amazon AWS services.

Example:

34.215.252.55:3023
34.213.39.98:3023
52.43.37.240:3023
52.33.59.1:3023
54.191.164.86:3023
54.244.109.176:3023

One that is interesting is the port 21587 is connecting to an private IP range:
10.188.112.163:21587 TCP:S

Once I allowed the 3022/3023/21587 access out, everything appears to work fine now. Can you tell I work in IT?

Zwift, please consider doing a connection check in your installation to confirm that users have all ports open or a note in the installer of the required ports, this could easily be done via a ping out on the set port in the installer. I know not many people may lock down their networks so tight, but with the way security is going and vendors are being pushed to make their devices more secure (routers) and windows firewall it could come in handy.

3 Likes

@Gerrie_Delport & @Bench , appreciate the help also and helping me walk through this and the suggestions.

@MatthewB You are welcome.

But i need to thank you for your patience and for your writeup on the solution, I think many users will find it very helpful.

RIDE ON :ride_on:

1 Like

Wow, I work in IT too and I would’ve never guessed that blocked outgoing ports could be the problem.
But I thought till now, everybody who blocks ports or keeps his firewall really tight is monitoring it to see if anything important wants to go through :smiley:

2 Likes

Welcome, hopefully someone else does find it handy, someone who is as over the top on securing their home networks :smiley: and Zwift adds those other 2 ports to their document page.

@Bench I think that is what got me at first, because everything else worked, companion app and the basics, which i guess all use port 80/443. This is why so many apps over the years have just gone to 80/443 instead of custom ports, largely to get around enterprise security, but it just simplifies things in the end.

I love my PFsense box! i see everything! When i first set up some Wyze camera’s on their own VLAN and saw them sending data to a Korean IP…(which they still have not answered me on) When they claimed all the data remained on North American AWS servers…

Knowledge is power!

First succesful event, that kicked my butt!