Starting an event issue

Hi there, I signed up for an event. In the Companion app I saw the status ’ GOING’ at this event and a timer on top, ’ Your race starts in 5 minutes’ .
In zwift I was free riding, waiting for the ’ join event’ message.

The timer went to 4,3,2 and 1 minute but still I did not get a ’ join event’ message. Neither in the App or on my laptop on which I run Zwift.
When the timer was zero and the race apparently started, I quickly restarted Zwift to see if I could join the race but again no ’ Join event’ message.

This is not the first time that this happens and it’s such a bummer to prepare for a race and then not being able to actually join it :-/ Any ideas?

when signing up for an event using the Companion app, don’t do it while you are on any of the Zwift menu screens. Do it before starting Zwift or while you are riding.

If that happen again and you see race stat in 5 with no join button , un-join the event in the companion app and re-join the “join” button should show up then.


Hi Gerrie, ok cool, I will try that :slight_smile:

1 Like

I tried the unjoin and join again trick but no luck. It happened twice on successive rides. Zwift…why not offer a hard coded Join button linked to the menu?

Has this been solved? I have been having the same issues the last three weeks.

I join evens ( rides and races) via the companion app. I see them in the event list once I’m on the windows app and they say i am enrolled and going. However I never get invited to join or see the menu option to actually join it…

Welcome to the forum @Carlos_Perez_Nafarra

When using the companion app, sign up before opening Zwift on you pc or wait until you avatar is on the road riding.

Do you see the map in the companion app while riding?

The map used to show on my companion app but it hasn’t done it the last 2+ weeks

I tried joining 3 different events within 30 mins of each other. I used the companion app to do it early in the morning.

I started riding 4 hrs later.

The events I selected were displayed on my PC app and they indeed display the “GOING” text and check mark next to them.

I rode 20 mins in free ride. My app kept counting down to my starting times for 2 of the events but never got the invitation.

I then switched to a scheduled training session and rode for 90 mins… two more events came and went and I never got the invitation…

The companion app was still counting down and letting me know when the events were about to start…

No luck. I’ll try a different computer today…

I would suggest not waiting for the event to take you to the start, at about 5 to 7 minuites to go just click “join Event”

That’s the problem. My companion is giving me all the info. but the zwift app is not giving me the option to join the event… Ever… I used to be able to join them just a couple of months ago… but something changed and now the zwift app displays that I’m enrolled but I don’t see any button or menu option to join the event… I’ll try on a different windows laptop tomorrow…

I tied on a different computer today. Fresh installation of both zwift on the computer and uninstall - reinstall of the companion app on my phone.

I enrolled myself 4+ hrs before the event.
I started riding about 40 mins before the event.
Same results as before. The app on the computer shows I’m enrolled. The companion apps counts down to the event.
I never got invited not saw a menu option to join the event manually…

Same here… it’s been the same for me for a month now…any solutions?

I assume you enroll using the companion app.

when you start Zwift do you see"going" next to the event?

While riding if you click on the scree do you see the menu button?

One more thing.

Is your computer time date and time zone correct?

I have the same issue. I have joined 2 events this week via the companion and the “join event” button never came up nor did the auto-select button transport me to the start line. I was only able to join when a message came up on the companion that the ride had already started was I able to join. I would love to be able to join an event properly, so any advice would be appreciated. Thanks!

I had the same problem but then I found a way to provoke the invitation.
Simply Start Ride in Watopia or another ride and once you do so, Zwift prompts you to join your event.

Apparently, just sitting there waiting for Zwift to send you the prompt doesn’t always work. The prompt looks like it’s set to interrupt you if you’re on a different ride, but not to get you to start the ride if you have just logged in - at least, not consistently.

If you’re under time pressure, it helps to know where your chosen ride is taking place so that you can start riding in the right location, before it prompts you to start the race. This speeds up the loading time.

Yes . And yes . I do se the menu option and do see that going check mark

I’ve tried this using 2 different computers and brand new installation on both . Never got the invitation. Both computers have the right date and time

And do you start riding waiting for the join event to pop-up in the lower left above the menu button?

A friend created a meet up this morning. I got the invitation and accepted it . Was riding 15 mins before the start. Never got called in.
I tried joining my friend directly. Zwift took me to his map (London flat route) but I never saw him… NOR anybody else for that matter! .
The map didn’t show any riders whatsoever…
I also tried just watching… from my computer and from the Android app on my phone… No riders on any map…

Is there something wrong with my account??

Never got any pop ups of any kind

If you never saw any riders, it sounds like you may have been having internet issues.

1 Like