No "Join Meetup" option for my Dad

Doing rides with father and Zwift+Facetime, which has been really heartwarming and amazing … when it works.

Most times I create a meetup (for the soonest time possible). I can see it and can join fine. My dad can accept it on his companion app and it shows him as “going” on my companion app. But then in game he sees no “Join Meetup” button. Inevitably the clock runs out and the event starts. We then try again. 10-15 minutes later and the same thing. Today tried 2 times unsuccessfully, and then eventually just started riding manually together. On a whim I tried one more time and this time it notified him and we got a successful meetup going.

A couple of notes:

  • I almost always create it for the soonest time possible. I often think about route choices and such as I’m filling out the form. Might it be that that time is no longer valid by the time I start (even though it is still in the future) and causing some bug?
  • My dad has his trainer paired to the companion app on his phone and that feeding data to the laptop running Zwift

Thanks for the awesome work, everyone. Amazing that I can ride with my dad during this pandemic and he’s on the other side of the country. Just want to get this worked out so we can ride each day and eventually do a race!

Hi - One thing some people miss is that you need to be “free riding” for the “join Meetup” button to appear. It doesn’t appear if you have started zwift and are sitting on the “choose world” screen.

Could that be the issue?

1 Like

There have also been some recent posts about Meet Ups that seem to say that riders are getting initial reminders to ‘Join Event’, but that after snoozing they are not getting the ‘Join Event’ button again in the last few minutes before the Meet Up is to start. I am, therefore, wondering if there is some issue with the Meet Up reminder and that by choosing the soonest available time you might be inadvertently falling inside that window, so your dad just isn’t getting the Join Event button. Pure speculation, of course.

I found this thread by trying to find a better answer to the same problem. But try this: have him open the companion app first, then zwift. If I do it the other way around I never get prompted to join the meetup.

^^ Those were the steps I was told, Companion app first, then open Zwift…

My issue was firewall ports. Can your Dad join any other events and get prompted to join them? If not, check firewalls, if any, router, windows et cetera to make sure ports
80/443/3022/3023/21587 are all open outbound or Events and such will not work.

1 Like