Meetup organiser not particpating in the meetup event

Has anyone had this problem with Meetups?
I create a meetup, invite followers, schedule the meetup, friends accept etc. The companion app shows that I am going. Zwift on the laptop shows that I’m going. The event nears (get no option to go early to the event, no automatic lift into the event as it nears). The event starts, my friends go on the meetup. I’m left alone (and I’m the organiser!!!). I have to select the course they are going on and play catch up to ride with them (but I’m not part of the meetup). Ironically, when the meetup is completed, it shows up on my history as a past meetup/event. It’s driving me nuts - it’s happened twice and I’m reluctant to schedule another wasted meetup. Thoughts anyone???

I logged on for this exact reason! The last two times I have scheduled a meetup the Join button does not come up. I have had to log out and race to log back in with 5 min to go. It also did not come up for 2 other riders who had clicked going. What’s the deal?

Also the rubberband was pretty glitchy yesterday. Had a rider get dropped.


Hi Bri,
I see that Zwift have just rolled out an update to the companion app . . . I’m hoping this might fix the problem. I’ll be scheduling a Meetup tonight for tomorrow morning (Australian time). Good luck and I hope it fixes your issue too. cheers PK

1 Like

yes having exactly this issue which is embarrassing as I’m organising the rides.
I wondered if possibly its something to do with Jarvis? Before this was added to my profile, the meetups worked just fine.
I’ve raised a support ticket this morning.

did this get fixed @Paul_Kelly3 ?

Hi all, I had the same situation. The window that redirects you to the meet up does not load. The same has also happened when I joined an event. So I wonder if there is any connection between the problem is originated when your Companion App is not connect to same WIFI as Zwift just before the event or meeting. Was it the case that you Companion app was in a different internet connection when that happen? Anyway it would be valuable to know the logic: " when exactly the window option to enter the event should appear.

Hello Mark,
Apologies for the delay but yes, the subsequent companion app update (bug fix) fixed my problem. I note that there have been two subsequent updates - one a another bug fix and ‘enhancements’ and the most recent the new functionality that allows up to 100 riders and a choice of which worlds to schedule a meetup. I wish I could tell you what to do BUT I can assure I didn’t change anything in my setup. The only changes made were those made through the Zwift releases. Same bike, trainer, laptop etc. I didn’t change any settings on anything. Only what Zwift has rolled has changed my situation. Hope that helps a little - cheers

I had this exact issue just today… everyone joined my meet-up but me. I created one an hour later to test (with just one other person) and it worked as expected…