Meetups not working

I tried using the meetup feature, so that my mother in law could ride with me. Unfortunately even though she accepted the invite, selected join event, and it placing her next to me at the start. She was not placed in the meetup, no count down, no meetup messaging, she couldn’t see my leader marker, and she didn’t show up on my ride list. We also couldn’t ride together.

I had a similar experience a few weeks ago when a group of friends tried to have a Zwift meetup.

I have a weekly meet-up with about 15-20 people and it seems that every week, one or two will accept the invite (and it shows as being accepted) and

  1. Not get beamed over to the meetup course (not receiving the final join notice), or
  2. Accept the final join notice, arrive there, only to be dropped before the countdown completes.
    Three weeks in a row!

How did it get resolved Zwift? It just happened to me

I have same problem 3 times this week. When the meetup start, I’m kick out.

It happened again earlier this week when there were a lot of zwifters on. It seems to fail for me when there are more than ~7,000 zwifters on at ounce. So maybe a server load issue? I imagine that’ll it’ll happen a lot with the quarantines in effect.

I had same problem Wed morning Australia time. The New York course was really busy. I was the organiser and hit the join button but never entered the meetup. Same thing happened to others. I then set up a second meetup 15 mins later - same issue. A