Late join not working consistently [June 2022]

I posted on FB ladies only group that the “join event” box on the new interface takes you to the event start HOWEVER, it does not send you to the event in progress if you join late. I exited the event and started a normal ride, thinking I was out of luck. I got the “join event” count down feature and clicked. I was sent to the start but notified that Zwift was looking for the group and I would be sent there. And I was, just like late join us supposed to work.

The ladies have been sharing stories about their frustrations of having to try multiple times to late join so I thought I would pass this issue along.

If my logs from my experience can be helpful, let me know. Maybe Zwift is already aware of this issue.

I late joined a number of events in the past few weeks, as you found I would join, be put in the pen instead of finding riders. I quit, went back in and it found the riders that time. I think this happened around 3-4 times (different events over these weeks).

Every single ride I have late joined since the most recent update, I am placed in the pen, not with the group the first time I join. If I quit and rejoin, then I am placed with the group. This happens consistently and did not occur before the update.

1 Like

It absolutely did. :wink: They were supposed to have fixed it with this release, but I’m not sure it’s worked.

1 Like

I was a serial late-arriver for most of my group rides prior to the last update and had the same problem, but of the couple of group rides since last week’s update, I was only late for one and it went fine (but that’s hardly conclusive).

Here’s the previous post relating to same issue. @JamesBailey may be able to check whether the fix actually made it into the current release.

I also joined a ride yesterday a few minutes late and had the same issue. It would not find riders. I tried 4 times on the same event and gave up after 15 min.

1 Like

This also happens in meetups. The problem seems to happen when the organizer is already in a different road than where the meetup started. If the organizer is still in the same road, then it works.

1 Like

When late joining a meetup, you get a message “finding riders” and you usually get teleported in middle of the group. However in the last two meetups this did not happen for two different people.

Late join works then you are getting the message “finding riders” but nothing happens for a while. Then you start riding alone from the pens for a few seconds and then you are teleported back to the beginnig! You can ride and catcup manually.

In both meetups, rubberbanding was enabled.

Quick question was one of the late riders the leader.

What operating system are they using?

yes, it was slow for me too. Others came and went, but i sat there. Klick on the remote (apple tv) a couple of times and then i was transported to the group - not sure if that was the reason or it just decided to work then.

This problem has been reported a few times before

https://forums.zwift.com/t/late-join-not-working-consistently/584603

https://forums.zwift.com/t/late-joining-event-and-dropped-in-pen-instead-of-group/583789

Looks like it’s related to the road where the group is riding. If they are still on the same road as the meetup started, late join works. If they are on a different road (passed by an intersection and changed road) late join fails. If you retry a few times it eventually works even if the group is on another road.

In some places (e.g. meetup starting at the jungle pens) the late joiner can be teleported to the underground (see video below)

https://cdn.discordapp.com/attachments/774428874640719872/977297445442707516/Zwift_2022-05-20_16-42-09-1.mp4

1 Like

Thanks! I don’t know how I missed those threads, as I searched to add my voice to a bug rather than starting a new one.

Indeed, both in meetups, there was a road split soon after the starting pens. And also, both those rides were in unusual maps for our group. With our usual maps, it did not happen for quite a while.

Probably unrelated with the latest update then.

Both times the leader was not riding at all. We run these meetups three times a week for two years now and it is not uncommon not to have the leader. I don’t recall any corellation of the two but we will try to find if there is a correlation.

One rider runs on mac the other on windows. One was time based meetup the other distance based.

Yes, it’s unrelated to the latest update, the bug has been there for a while.

I think it’s also unrelated to the leader being present or not, I tested with only one other person (who was the leader) and the problem happens (see video in my previous reply).

I’m almost sure it’s about the road. With the old home screen, if you select “ride with” a friend who is in the meetup, then join the meetup, it works even if they are on a different road than where the meetup started.

I have this problem consistently since recent update. Late join to banded private meetups, tried 5+ times finding riders, didn’t work. Never seen it before.

1 Like

I’ve found a work around to this(I think…). What works for me is fanviewing a rider who is currently in the meetup, within a few seconds, it should bring you to the group.

Today I experienced a serious technical glitch in the software, that others have also experienced. The ‘late join’ / ‘rejoin’ feature is broken. But that isn’t the only issue. I will describe in detail what happened today:

It took a very long time for Zwift to load and I started loading it 15 minutes before my meetup ride. It is my fave ride of the week. Once loaded, it did not recognize either my Ant+ connection or my Bluetooth connection, so I had to restart my computer.

Then, when I restarted, it again took a long time for Zwift to load. I clicked to join my meetup ride, but it took a very long time for Makuri Islands to load. As it was still loading the meetup began. When it finally loaded the meetup was only one minute in (I was only 1 minute late and only because of the software), but it said “Finding Riders” and I was 1:38 behind the group. They could see my chat, but they could not see me and I could not see them. I tried catching up, but to no avail. Finally, it just kicked me out of the meetup.

I have heard others say that the late join / rejoin feature has not worked for them since the last update.
I pay a lot of money for this software and have been a loyal user / rider for nearly 3 years. It seems that an update fixes 2 problems but breaks 5 new things. Doesn’t Zwift test the software update before pushing it out to customers? Most of the updates tailor to the racers or the professional riders, but I believe that is a very small minority of the customer base. Most of us are simply cyclists using the software to stay in shape and socialize.

Please fix these issues (and test them before pushing them out) as they caused me to miss my favorite ride of the week. And I am a voluntary ambassador (not official) as I always encourage people to sign up for Zwift, I lead a couple rides each week, and I help new Zwifters learn the software.
Thank you.

Major issues with meetups since last Monday: rubber band does not hold group together, any late joiners do not find riders and are started at other parts of the course, some can’t get into the meetup at all. PLEASE FIX!!! We have a devoted group of morning meetup riders and this is killing us.

HI @Emily_Collier welcome to Zwift forum.

Shuji at Zwift HQ here. Thanks for reporting these Meetup issues. We’re investigating why this is happening to you.

I see that you’re running Zwift on a Windows machine, and running the latest version of the app. Would you know if everyone in your group is also on Windows, or is it a mix of different OS platforms?

1 Like

I believe we are using different platforms among our group (quite large, 10-15 riders). Actually Jess above is also a part of the group.

1 Like