Late join quits event immediately

Hi Team, I noticed a bug now twice.

Last week and today morning in the EVO 160km ride late join was not working.
It joined, found the ride but then the event quits immediately and I found myself alone in the world.

I tried several times but still the same behaviour.

I use Zwift on a Windows PC.


I don’t think I’ve tried late join since the latest release so this could be a new bug. When you say alone in the world, do you mean you were dropped back into the “regular” open-ride world containing other (non-group-ride) riders scattered throughout it? Or do you mean literally you couldn’t see any other riders at all, almost like you were in a separate copy/clone of the EVO group ride event all on your own with no other riders at all visible?

Also just to check, you didn’t “late join” right in the closing couple of seconds of the (30 minute?) window? i.e. its not possible tha tyou late-joined while still technically available but by the time your PC processed the ride/data etc the late-joined had lapsed/expired by a second or two and was no longer avaailable? Or was there still plenty of time available?

(I’m not zwift support, just trying to get more info to understand the issue. I do group rides too so I’ll watch out for this happening also)

I was trying to join 5 minutes after start. So alot of time remaining for late join.

I automaticaly see race report (see pic) and then land in the real world with other riders.



That’s pretty odd, and it looks like two others had the same issue did they? (the two others also showing in the “finished” list)

Am I reading that screenshot right that your ride time was 3 seconds, but the “event” time for the ride was 4minutes45? Does that 4minutes45 map to anything you can think of? Were you warming up for that time elsewhere before joining the event for example?

Also, had you “signed up” to the event via companion app in advance? Or did you join on a whim/without previous signup from the “upcoming events screen” on the zwift homepage?

Just trying to gather as much context here as possible to try and figure how to reproduce this

The event time dosn’t mean anything. I tried several times also earlier or later.
Also I tried both ways. Joining the the event from the homescreen and joining from another world, both the same result.
I signed up the day before via companion app.

thx for asking :wink:

Anyone hear of any updates on this? Has been happening to me on every late join for the last week. It’s horrible.

Had a Zwift customer support chat and they’re aware of and hopefully working on a resolution. We should hear of an update on this forum.


As the saying goes, they’ll doubtless fix it… “zoon”…

Seems to be a number of problems with late joining events, I had one where I was able to join the event (Trek ride) going on the foothills ride, I went through the desert, through Titans Grove but at the end instead of turning left with the group Zwift sent me right back into the desert on my own - that’s end of the ride at that point.

Hopefully they will find a fix. I’m doing a few rides also on Ful Gaz at the moment to get in some of the big classic climbs while Zwift finds a fix to it. To be honest I don’t do that many event rides at the moment.

I have the same late join bug as well. Any solutions yet?