Joined Event But No Other riders

I signed up for an event, my first, and got a notice to join the event but when joined there were no other riders and then ride started and it was only me. So I stopped and changed courses as ride was on a course not open today so no other riders. But when I went to the other course all the messages in the Zwift App were for the ride I had tried to join so showed other riders. Not sure what I did incorrectly as did what I did last year for Tour de Zwift and it worked fine.

Sounds like a network dropout. Did your connection get interrupted during the ride? I believe you can enter the file at to find out if you lost connection.

1 Like

No when I joined it put me at the line with the clock counting down my avatar on a trainer. Just no one else there and there were a lot signed up.

I’ve had that happen too. I just rode the event, and within a couple minutes, the rest of the group suddenly appeared all around me. It was a little weird though, while I was riding all alone

@Tony_Konvalin have you found a solution to this? I am having the same problem and every attempt to fix it has failed.

Never got a response but think Mike who commented above had the answer as I had something happen during an event where my internet went down for a few minutes but I was still riding but everyone disappeared and then suddenly they came back but I had been dropped. The only thing to do was quite and come back in as event allowed late starts. I think the issue is my internet then either went out or got so slow it was then running locally and lost other riders.

Hi folks, just started joining events. First couple of occasions it’s been fine. Yesterday I froze mid ride on 3 occasions and finally gave up. Today when I joined the event, my kit changed but I stayed in the wrong world ( did notice 3 similarly dressed riders) rebooted 3times and then found I was transported to correct world but Zwift couldn’t find the riders, so again gave up. Ive reinstalled Zwift and no difference. Anyone any ideas? (Zwift on an iPad btw) cheers

This happened to me too. I tried 3 different rides and for each one it was just me. I could see the other rider numbers but no one else.

Lara I think I may have the same issue, just started today. 7AM joined a meetup and I was all alone (despite the internet working fantastic, and having ridden 12 hours earlier just fine on same setup). Now the rest of today I cannot see anybody on 3 separate computers in this house, though my wife’s account and my kids account work just fine. I think something might be up at Zwift HQ?

I have a similar issue. I cannot join events or meet-ups at all anymore since a couple of weeks. I had no issues in the past. I sign up for a meetup. Start zwifting ahead of time. 5 minutes before the meet-up starts I press ‘join event’ and… nothing happens! I just stay in the world/route where I am. Rebooted several times but to no avail. I have now missed several meetups. This is so annoying. Re-started Zwift and no change. Re-installed Zwift and no change. This is a reason for me to cancel my subscription. I do not know what to do about this anymore.