Meetup Mix up - Rider and Runner

Hi all,
Bit of an issue yesterday. which i will try to summarize below.

Tried creating a meetup with another rider. The other rider accepted but was never shown a ‘join event’ option.
I had accidently created it as a running event.
Recreated the meetup as a ride and the same issue, no ‘join event’ option.
He created a ride meetup and I joined.
He was on foot and I was on a bike ?!?!?
No matter how many ways we tried it ended with the same result. Me on a bike, him on foot.
Wasted 40 minutes trying to set this up before giving up.
Went on the Rower instead.

Both of us were using iPads (Zwift) and iPhones (Companion).

Tacx Flux S and Tacx Flux 2 trainers for what its worth. Not sure that should have any impact on this though.

We have used this same setup before without issues.

Any suggestions? We are going to try again later today.

I’ve got to say that so far the Customer Support from Zwift has been completely lacking for every issue I have raised. ‘Buy more hardware’ is the standard response even after I point out that other platforms have no issues.

Thanks in advance for any help.