Sensor Garmin Signal Issue

Hello. I have 2 Garmin 2 sensors, 1 speed 1 cadence for about a month now. Everything worked perfect until today, when there is a issue with speed sensor s signal. The battery has been replaced, it s new so that should not be an issue. As soon as I search the sensor in Zwift to be able to go ride, the app finds the sensor, I proceed to the screen where you are supposed to select world and route. As soon as I start spinning the signal from the speed sensor drops and what is shown on screen is that the sensor is connected but there is no signal. I did reconnect the device on bluetooth did restart zwift did try zwift on laptop aswell as on mobile and the same happens. The only thing that is different from some day ago when I last used them is that the game got an update. Any advice?
Update: I did reconfigure the garmin speed sensor on my garmin connect app and started working but now the cadence sensor is dropping signal. After some more tries now both sensor lose the signal. I don t know whay the issue is I rebooted phone and network signal, nothing working. Tried zwift on my phone and also through zwift companion on laptop same issue.

I have the same issue. Contacted Zwift via messenger and got the advice of how to pair but that isn’t the issue. After a simple couple of answers the IT dude, probably with a pony tail, simply stopped replying.
I think it was as soon as I mentioned iOS.
Is there a known issue I wonder?

1 Like

So I have an iPhone 11 Pro and my brother got an iPhone 7 that he also uses companion on the same zwift account. After trying 16728281 solutions, it crossed my mind to try with my brother s phone and guess what! Both sensors connected no droping signal, everything working fine. So I think the issue is the phone, maybe some bluetooth issues

This is definitely an issue with the last update. Has to be. Sadly no one seems to be able to come up with a suggestion.

Well if the issue is not solve until 7th I will simply cancel subscription, seeing that they are not able to come in help on the forum or anywhere else. Poor Support Service

1 Like

Same problem here today!
Speed sensor no Signal!
Did anyone fix it?

Nope, only using another smartphone it may work.On my iphone 11 pro there was the issue that I was talking earlier, but when I took my brother s iPhone 7 and installed companion everything worked fine, so idk what s the issue with my phone

1 Like

I will try the other phone

Let me know if this also worked for you

Worked with another phone!
Thank you

Yeah still this is not a proper solution because I can t be using some one s phone always

I also have had the same problem today I’m using an Android phone. Also had this problem a few days ago. Really I’m getting fed up with this now bike all set up and can’t even go on it.

Did you manage to make it work somehow?

No still no luck :frowning:

In the end I gave up and connected the sensors on an all in one desktop and to my surprise it worked. So I will keep it on the PC.

Doesn’t work if you have android phone as no option to pair sensors.

This is really annoying. It worked fine before I updated to the latest Zwift release; I’ve now spend half an hour trying to get it all to work and am getting really annoyed as I don’t have the time to waste on this.

I wouldn’t mind so much except I’m paying a monthly sub for something that is currently unusable.

Did you check that Zwift has all the needed permissions (Photo, Bluetooth sound ect)

Yes. As I say, nothing had changed apart from the Zwift app update, prior to which all worked fine.

iPad OS 13.4.1, iPad Air 2, Garmin dual band sensors.

My thinking was that the new update require different permissions.