Zwift not recognizing Garmin speed sensor

I’ve been riding with Zwift using Garmin cadence and speed sensors on my bike. Today for some reason only the cadence sensor is being recognized, so my avatar won’t move at all. I know it’s not a battery issue because my Garmin watch still recognizes the speed sensor. Zwift is saying “No Signal” from the speed sensor sometimes, but sometimes it seems to read a signal and still doesn’t produce a speed or watts. Any suggestions? I’ve tried restarting multiple times. Very frustrating. I just had to miss one group ride and am hoping not to miss another!

I have exact same problem. I have missed 3 group rides. Very fed up! I have tried brand new Garmin Sensors with brand new Mac and still no recognition. I have only a classic turbo trainer, brand new Garmins and my Iphone 7plus. No joy, sometimes they connected but by the time i got to the ride, my avatar just sat there. Sometimes nothing would connect, sometimes just the speed sensor. I have just tried the whole thing from scratch using my son’s Mac and my new Garmin sensors, and it just won’t pick them up.

1 Like

Thanks, Cranky. Misery loves company. Yesterday it worked for me 2 hours after it didn’t work-- very frustrating how random it is. I’ll be sure to post if I learn anything more.

This is (or at least should be) a known issue following the latest update.

Are you using an iPad by any chance?

Thanks, Andy. I’m using an iPhone 11, not an iPad.

New to Zwift so didn’t know if this was a known issue or a new issue or something I was doing wrong

Just tried to join in on Zwift. Garmin cadence sensor shows as linked and gives a reading. Garmin speed sensor also shows as linked but shows 0 speed. I see this is a common problem. Why?