No signal for speed & cadence sensor 2 from Garmin

Since the last update V1.0.49822 on IPad, I get a “No Signal” for the speed and cadence sensor 2 from Garmin. I know they work as when opening the Kinetic App, I can see them.
It was working fine before the update. I tried to reinstall the App, reconnect the Bluetooth, remove battery on the sensors, but nothing changed.
I used my iPhone where I did not yet update the App, and it works fine, so it’s most likely an issue with the update.


Hope there will be a fix very soon.

Bluetooth can only pair to one thing at a time so make sure it is not connecting to anything else. Forget the sensors on all possible devices.

Thanks for advice, but I had all other devices with Bluetooth off in order to avoid any interference, but even so, it did not work. After spending too much to find a fix, I decided to use my iPhone, and it works straight away. Hopefully there won’t be the same bug once I upgrade the app.
I really think it’s a bug in the last version of the App, since it worked perfectly until I did the update.

1 Like

Yep, same issue here (in my case, the cadence sensor connects fine, it’s the HR strap and wheel sensors that don’t) only since the update; anecdotally others having the same problem.

This has to be a bug. It’s not a pairing issue as the advice has always been not to pair the devices, but to connect via the app.

I found this in another forum:
“Best resolution I found was to launch Zwift ‘Just watching’ with ‘no signal’ messages present, then immediately end ride and delete. Go back to the pairing screen and all 3 devices will magically connect fine”.
I will try this later on.

1 Like

Thanks, I will give that a try too.

I tried but it did not work. So I used again my iPhone with the previous version. I guess we will have to wait for the next release. It’s also not being able to read the cadence from the home trainer. It shows 0, but when I use the Kinetic App, then it shows it correctly.

No, I had to resort to using my phone too (oddly, it’s on the current release too and worked fine)

Hi Andy, I have exactly the same problem as you, since the latest Zwift update, which coincided with an IOS update neither of my Garmin 2 sensors worked, they were detected but I got the same “No Signal” message as you. The Garmin sensors work on my IPhone 7 but not on the 6th gen IPad. Like you I have tried all the solutions touted on this forum but to no avail. So today I downloaded Zwift on to my wife’s IPad mini and both Garmin 2 Sensors ( speed & cadence) worked. My 6th gen IPad has IOS version 13.4.1 installed and my wife’s IPad mini has version 12.4.6. I am aware this not a solution to our problem but perhaps indicates that there may be a conflict with the latest Zwift release and the most recent iPad operating system. Hopefully it will be resolved sometime soon. Cheers Mick

Yes, let’s hope so.

There doesn’t seem to be a pattern to this; I had t working fine on my phone but not my iPad (both running 13.4.1) but anecdotally it’s worse with iPads.

I raised it with Zwift support last weekend but thus far… silence.

And now on my iPhone, I get a No Signal for the HRM… sooo annoying, as no device can get all the data…
It’s very frustrating that there’s no response from Zwift support, no solution, no workaround!
With the subscription fee, I wish they would give better support…

Completely. Had the same issue on my iPhone on Tue, only solved by a restart.

I’ve raised a support ticket but no response. This is really disappointing given the monthly fee.

I’m having the same issue too, Garmin Cadence 2 worked perfectly, Zwift updated it connects but no signal??? New battery installed, deleted and re installed Zwift app on my iPhone, still no joy.

I know it is working as I use my Edge 520 as back up and registering cadence perfectly well on the bike computer, tried it with the Edge off too, still no signal.

Frustrating as I know it was working perfectly well prior to the last big update 1.0.49617

Having the same issue as everyone else, immediately get the “No Signal” on my iPhone that has always worked before the last app update. Oddly enough, I can get the HRM and Speed sensor to work on my son’s iPad but the Cadence sensor isn’t really reading, or Zwift is overriding it with bogus values because it’s always between 20-60, where my Garmin unit shows the correct values between 65-105. I can also run on my iPhone with only the Garmin HRM and my Stryd, so it’s something to do with the combination of several Garmin monitors at the same time, I think.

Zwift support just got back to me over a week later, but I don’t think they read my very detailed message, because all they suggested was that I look at their list of sensors that are compatible with Zwift. Sigh. Hopefully this gets fixed soon.

Finally got a reply from Support.

The words ‘chocolate’ and ‘teapot’ sprung unbidden to mind.

They’ve escalated to Tier 2 but this has to be a known issue given the umber of reports on here/other places?

I bought mine for 2 weeks ago and everything worked fine both Garmin connect an zwift worked fine the second i updated my IPhone to 13.5 both are not working on my IPhone since. Garmin connect is not pairing and Zwift with No Signal. Zwift on my laptop is working fine. Conclusion is that i think it is IOS update that did it because Garmin connect is not working too

1 Like

It is happening to me as well. But instead of using my iPhone, I used my iPad and everything worked just fine. It seems to be an issue as you said with the version. Have you tried to reset your network settings? maybe that could work. I haven’t tried that yet as I’m going to continue using my iPad meanwhile.