Screen grabs no data on image

Hi guys.
May have been asked before but
can’t find a solution. Having a nightmare with Screen grabs. Every photo I take on Companion is a clean image. My app has full permissions and the very 1st 2 I took during my 7 day trial have the data on.
I uninstalled and reinstalled the game on my laptop as I had conductivity issues with my Garmin Sensors.
I’ve tried in the images at the end of the session, turning authorise on and off again, I’ve also clicked on and off the top right corner and nothing works.
Is there anything in the Zwift config pref files I can change. Doing my nut in atm.
TIA

On what sort of device are you running Zwift? I use Apple TV and you can toggle back and forth between them actual ‘photo’ and the clean version and choose which one you want. (Technically I guess it’s actually two shots taken a fraction of a second apart, but you still choose which one you want.)

So you are saying you take a screen grab but after saving its not in the companion app? Or not on strava? I know strava can block the images. But you seem to be saying you can’t get any image on zwift companion?

I am using a laptop running windows 10 and use companion on my Samsung Gakaxy S9.

Ben. Nope. I take a screen grab and at the end when I view my grabs before saving my ride there is no “dashboard” info on any of them.

Found this

Which is the opposite of your problem. Try playing with the upload images options.

Cheers Ben, I will have a look into that tomorrow. Off for some kip now.

Tried everything. Even uninstalled the app from my laptop and my mobile, pre-installed and still have the same issue. At the end of my session before saving the images are just blank, click on the logo top right and then the clean image comes up. Very frustrating.