Saris H3 flashing blue light & no erg mode

Hello,

I have a new Saris H3. I have riden it for about 6 hours. For the last 3 sessions erg mode has not worked. I noticed the led was flashing blue rather than constant like it once did.

I have:
Updated the firmware
Updated my android phone
Updated the zwift app
Made sure it’s connected as a controller via Bluetooth
Calibrated the turbo
Turned it off and in again (many times)

Is there anything else I can try? I cannot get through to either saris or zwift telephone help lines and they have not responded to my email.

Thanks in advance!

I have exactly the same situation. Everything was perfect pre-april 1st, now zwift won’t control my H3 which is super frustrating.
I have also emailed them but no reply yet, I’m hoping that they are dilligently working on a bug fix ti send out asap!

I am having this same issue. I only got my trainer today, connects to the Saris App and works fine, solid blue LED and erg mode works.
Every time I connect to Zwift, instant flashing blue light, power and cadence show but resistance doesn’t change and erg mode doesn’t work.
Not using trainer or Zwift until this is resolved.
Interested to know what the answer is to resolve this problem. Highly frustrating

I have noticed the same thing when I tested with Android 10 on a OnePlus 6T with a Saris H3 trainer.

No resistance change commands get send to the trainer.

The trainer works perfect on Windows 10 ANT+ FE-C.

I have the exact same issue. H3 connected via Bluetooth to my tablet. Very frustrating.

Hi Gerrie, are you saying that it works fine with ANT and windows even after the april fools update?
Anything special i have to do to switch over to ANT+FE-C? I have an older dongle that i assume is the right thing to stick in my laptop.
Thank you!

Yes ANT+ fe-c on windows work 100%.

:+1: awesome!

Hey. Is there a way of connecting to my phone using ANT instead of Bluetooth? I can only get zwift on this device. Thanks.

@Peter_Kirby

Some Android devices has ANT+ abilities. But that is in Beta on Zwift.

see ANT+ Update?

Are you guys using the Beta version of the Android app? I am and was wondering if that may be the issue but don’t want to roll back if no point. My version number is 1.0.48307

No I tested it with the latest Andriod build.

I used Ant+ and it was still the same. Very frustrating.

Ant+ on Android?

Yes, I have a Samsung phone and tablet that are ant+ enabled.

I have exactly the same problem on Android (Pixel 2) and Bluetooth. No resistance adjustement at all. Trainer works perfectly in ERG mode with TrainerRoad and bluetooth. I originally thought this was due that my Garmin Unit (I record in parallel due to TSS not being taken into account otherwise) overriding the trainer, but the problem subsists even with the Garmin off…

Same issues as everyone else… Hammer H3 ERG mode does not work on android for both Bluetooth and ANT+. Works fine using either Bluetooth or ANT+ on Win10. Has Zwift acknowledged the issue? Is there a fix coming in the next release?

1 Like

I managed to speak to Saris support. They confirmed they had the same problem with their trainer and had alerted Zwift. I have spoken to Zwift via the support email but it has not got to a resolution yet. Here is hoping!

Hi there, same problems here … Saris H3 is not controlled by the Zwift app, no resistance adjustment, flashing blue light … a little bit frustrating. I hope, the problem will be solved soon.

Hi - I have had this on and off. I have done a couple of things that have so far worked. I have changed my wifi channels to reduce any interference. I have also mixed the connections. Power and cadence are over bluetooth and the controllable over ant+ fec and it seems to have been ok since.