Saris H3 cant Update firmware

Recently bought a new Sairs H3. No problems getting set up with a desktop PC attached to a TV and using Ant+ USB dongle
Only use Zwift and have not installed companion app so no bluetooth in the mix. PC does not have bluetooth
Was noticing some issues with cadence dropping out esp in ERG mode so thought I would check/update firmware. To do this I installed the Saris app on my android phone. Then turned on bluetooth. I plug the Saris in and it flashes green but will not connect to the App until I pair the H3 with my phone. Then the Saris blinks blue and I am connected. However when I click firmware it shows my version (old) but does not give me any new versions to update to??
I am able to do the other things like calibrate and check device setup and these seem to work so its not like they are not talking to each other?
Saris support said to uninstall and reinstall app but this didnt help. Also tried on someone elses phone same outcome

Hi @Julian_Taylor1

welcome to the forum

I also have a H3. Try turning your computer off.

Thanks but yeah tried that too and no luck…

Actually out of interest does your H3 blink blue (rather than green) when you update the firmware assuming you are doing it via phone/bluetooth. The guides all seem to say check light is flashing green but for me it goes from green to blue as soon as I pair via bluetooth. Just wondered if it somehow had to be in green flashing mode to update firmware but dont see how this is possible

@Julian_Taylor1 :

Here is the documentation on what the Saris light means:

It has been several weeks since I upgraded the firmware in my H3, but if I recall the light was indeed blue (not green) when I upgraded the firmware, which is what the above docs imply.

One idea: maybe try to upgrade the firmware using the Saris app on an iOS device? I had no problems using my iPhone to update my H3. I have certainly encountered devices where the Android app was buggy w/ certain Android models but the iPhone app worked fine (or vice versa). Hopefully you have a friend or family member that can stop by that owns an iOS device, or borrow an ipad or iphone for a few minutes.

Another idea: If you have any other bluetooth apps on your phone that would connect to your trainer (Zwift, TrainerRoad, …), make sure those apps are not running when you launch the Saris app.

Hope this helps!

Yes I had seen that document before. Good to know it is the blue light

Hmmm well worth trying the ios app but dont know anyone off-hand that has a iphone or pad they are willing to lend. Will have to ask around. Good suggestion

I’ve had the same issue for 3 years. I’ve never been able to update the firmware. I was lucky. I rode erg training exclusively for two years with no issues. I’ve never had lasting issues with the trainer.

I will do a few tests this morning once Im done riding.

It should just work on android.

If you know someone with an iPhone or iPad you can try that route. I used to have an Android (well actually still do) Pixel 2XL and its BT was finicky. IME BT is the most stable on iOS devices…but that is not saying much.

I updated my H3 a couple of weeks ago. I used my iPad and it took two tries…the first locked it up. After hard close and re-trying the firmware was installed.

What FW version do you have. Mine is 3.059 (I think) and appears to be quite an old one. I find in a workout in ERG mode that for example if I have to hold 220W for 5 minutes at 100 rpm that there is not enough resistance to get to 220W - I have to increase rpm to 107 for example. Also once or twice the cadence just drops to zero and I come to a stop. It is certainly usable just not 100%

Hmm finding an ipad/phone may be difficult. Have someone visiting in early Jan that has one so might have to wait till then. Annoyingly had someone stay recently who just left that had an ipad

OK would be good to know what you find out. I haven’t heard back again from Saris support…

I have no idea. iphones,android,pc all a waste of time and energy. Customer service stopped responding to my questions but they did send me this 10 page how to type thing that was laughable. then they told me i had to sign up for rouvy(?) and 100% it would work. I gave up 2 years ago and things work. I would never pick up on those kind nuances.100-107 would be the same in my book. Id just chaulk that up to my poor cycling abilities.

I just opened the saris app and it found my trainer instantly.

Make sure it is not in the phone Bluetooth settings. Also not connecting to the pc

OK made sure H3 is not in bluetooth settings.
Cleared data for the Saris App
Plugged H3 in. Green flashing light. H3 not found until turn on bluetooth (but not pairing anything in bluetooth)
H3 found in app. Go to firmware, brings up my version but does not offer any newer versions. Strange
Thanks for trying!

I’m having the same experience as Julian. This has happened to me before and Saris recommended I change my location settings. I’ll try that tonight and let you know if that fixes it.

What location did Saris say to change to? On my phone the region is currently set to New Zealand

Saris told me I couldn’t have location services turned off on the app. I have no idea why. Once I changed it to “while using” the app would connect to my H3. Even the customer service rep had no idea why that made a difference.

That has something to do with Bluetooth using some code in the location services. That also happen with the Zwift app and many others.

Good news I have managed to update the firmware on my Saris H3

Unfortunately I don’t really know why it worked this time

I had a friend come around who had a Apple iphone. However with her phone we could not even connect to the Saris at all through blue-tooth. (her phone could connect to our other device via bluetooth so strange)

I tired my android phone again and still only got to the same point as previously

On a whim we thought we’d try my partners android phone again (which had also failed on previous attempts)

This time it worked!

The only thing I can think of is that her phone uses the 5G option of our wifi whereas mine uses 2.4G (no option to use 5). Secondly maybe this time around the steps we followed with her phone were the right ones eg not plugging in H3 until Saris utility is launched and so forth.

Anyway pleased that I dont have to go through the hassle of a warranty claim